40ec33bbb2ca294ddea7ae6ed41bb40db52b889e
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0.82
8 Release: 6
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 ## check for ccache
38 if ccache -h >/dev/null 2>&1 ; then
39         CC="ccache gcc"
40 else
41         CC="gcc"
42 fi
43
44 export CC
45
46 ## always run autogen.sh
47 ./autogen.sh
48
49 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
50         --prefix=%{_prefix} \
51         --sysconfdir=%{_sysconfdir} \
52         --mandir=%{_mandir} \
53         --localstatedir="/var"
54
55 make docdir=%{_docdir} showflags
56 make docdir=%{_docdir}
57
58 %install
59 # Clean up in case there is trash left from a previous build
60 rm -rf $RPM_BUILD_ROOT
61
62 # Create the target build directory hierarchy
63 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
64 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
65
66 make DESTDIR=$RPM_BUILD_ROOT docdir=%{_docdir} install
67
68 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
69 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
70
71 # Remove "*.old" files
72 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
79
80 %preun
81 if [ $1 = 0 ] ; then
82     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
83 fi
84 exit 0
85
86 %postun
87 if [ "$1" -ge "1" ]; then
88         %{initdir}/ctdb restart >/dev/null 2>&1 || true
89 fi      
90
91
92 #######################################################################
93 ## Files section                                                     ##
94 #######################################################################
95
96 %files
97 %defattr(-,root,root)
98
99 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
100 %config(noreplace) %{_sysconfdir}/ctdb/notify.sh
101 %config(noreplace) %{_sysconfdir}/ctdb/functions
102 %attr(755,root,root) %{initdir}/ctdb
103
104 %{_docdir}/ctdb/README.eventscripts
105 %{_docdir}/ctdb/recovery-process.txt
106 %{_sysconfdir}/ctdb/events.d/00.ctdb
107 %{_sysconfdir}/ctdb/events.d/10.interface
108 %{_sysconfdir}/ctdb/events.d/11.natgw
109 %{_sysconfdir}/ctdb/events.d/11.routing
110 %{_sysconfdir}/ctdb/events.d/20.multipathd
111 %{_sysconfdir}/ctdb/events.d/40.vsftpd
112 %{_sysconfdir}/ctdb/events.d/41.httpd
113 %{_sysconfdir}/ctdb/events.d/50.samba
114 %{_sysconfdir}/ctdb/events.d/60.nfs
115 %{_sysconfdir}/ctdb/events.d/61.nfstickle
116 %{_sysconfdir}/ctdb/events.d/70.iscsi
117 %{_sysconfdir}/ctdb/events.d/90.ipmux
118 %{_sysconfdir}/ctdb/events.d/91.lvs
119 %{_sysconfdir}/ctdb/statd-callout
120 %{_sbindir}/ctdbd
121 %{_bindir}/ctdb
122 %{_bindir}/smnotify
123 %{_bindir}/ping_pong
124 %{_bindir}/ctdb_ipmux
125 %{_bindir}/ctdb_diagnostics
126 %{_bindir}/onnode
127 %{_mandir}/man1/ctdb.1.gz
128 %{_mandir}/man1/ctdbd.1.gz
129 %{_mandir}/man1/onnode.1.gz
130 %{_includedir}/ctdb.h
131 %{_includedir}/ctdb_private.h
132 %{_libdir}/pkgconfig/ctdb.pc
133
134 %changelog
135 * Tue Jul 14 2009 : Version 1.0.82-6
136  - change loglevel for registering tcp clients
137 * Wed Jun 10 2009 : Version 1.0.82-5
138  - When banning a node, only drop all ips on the node being banned, not all nodes.
139 * Tue Jun 9 2009 : Version 1.0.82-4
140  - dont delete the socket when exiting ctdb
141 * Tue Jun 2 2009 : Version 1.0.82-3
142  - Make ctdb statistics support machinereadable output
143 * Tue Jun 2 2009 : Version 1.0.82-2
144  - Add machinereadable (-Y) output to ctdb listvars and ctdb getvar
145  - track how long it takes for ctdbd and the recovery daemon to perform the
146    rec-lock fcntl() lock attemt and show this in the ctdb statistics output.
147 * Thu May 14 2009 : Version 1.0.82
148  - Update the "ctdb lvsmaster" command to return -1 on error.
149  - Add a -Y flag to "ctdb lvsmaster"
150  - RHEL5 apache leaks semaphores when crashing. Add semaphore cleanup to the 
151    41.httpd eventscript and try to restart apache when it has crashed.
152  - Fixes to some tests
153  - Add a -o option to "onnode" which will redirect all stdout to a file for
154    each of the nodes.
155  - Add a natgw and a lvs node specifier to onnode so that we can use 
156    "onnode natgw ..."
157  - Assign the natgw address to lo instead of the private network so it can also
158    be used where private and public networks are the same.
159  - Add GPL boilerplates to two missing scripts.
160  - Change the natgw prefix NATGW_ to CTDB_NATGW_
161 * Fri May 8 2009 : Version 1.0.81
162  - use smbstatus -np instead of smbstatus -n in the 50.samba eventscript 
163    since this avoids performing an expensive traverse on the locking and brlock
164    databases.
165  - make ctdb automatically terminate all traverse child processes clusterwide
166    associated to a client application that terminates before the traversal is
167    completed.
168  - From Sumit Bose : fixes to AC_INIT handling.
169  - From Michael Adam, add Tridge's "ping_pong" tool the the ctdb distro since 
170    this is very useful for testing the backend filesystem.
171  - From Sumit bose, add support for additional 64 bit platforms.
172  - Add a link from the webpage to Michael Adams SambaXP paper on CTDB.
173 * Fri May 1 2009 : Version 1.0.80
174  - change init shutdown level to 01 for ctdb so it stops before any of the other services
175  - if we can not pull a database from a remote node during recovery, mark that node as a culprit so it becomes banned
176  - increase the loglevel when we volunteer to drop all ip addresses after beeing in recovery mode for too long. Make this timeout tuneable with "RecoveryDropAllIPs" and have it default to 60 seconds
177  - Add a new flag TDB_NO_NESTING to the tdb layer to prevent nested transactions which ctdb does not use and does not expect. Have ctdb set this flag to prevent nested transactions from occuring.
178  - dont unconditionally kill off ctdb and restrat it on "service ctdb start". Fail "service ctdb start" with an error if ctdb is already running.
179  - Add a new tunable "VerifyRecoveryLock" that can be set to 0 to prevent the main ctdb daemon to verify that the recovery master has locked the reclock file correctly before allowing it to set the recovery mode to active.
180  - fix a cosmetic bug with ctdb statistics where certain counters could become negative.
181 * Wed Apr 8 2009 : Version 1.0.79
182  - From Mathieu Parent: add a ctdb pkgconfig file
183  - Fix bug 6250
184  - add a funciton remove_ip to safely remove an ip from an interface, taking care to workaround an issue with linux alias interfaces.
185  - Update the natgw eventscript to use the safe remove_ip() function
186  - fix a bug in the eventscript child process that would cause the socket to be removed.
187  - dont verify nodemap on banned nodes during cluster monitoring
188  - Update the dodgy SeqnumInterval to have ms resolution
189 * Tue Mar 31 2009 : Version 1.0.78
190  - Add a notify mechanism so we can send snmptraps/email to external management systems when the node becomes unhealthy
191  - include 11.natgw eventscript in thew install so that the NATGW feature works
192 * Tue Mar 31 2009 : Version 1.0.77
193  - Update the 99.routing eventscript to also try to add the routes (back) during a releaseip event. Similar to the reasons why we must add addresses back during releaseip in 10.interfaces
194 * Wed Mar 24 2009 : Version 1.0.76
195  - Add a debugging command "xpnn" which can print the pnn of the node even when ctdbd is not running.
196  - Redo the NATGW implementation to allow multiple disjoing NATGW groups in the same cluster.
197 * Tue Mar 24 2009 : Version 1.0.75
198  - Various updates to LVS
199  - Fix a bug in the killtcp control where we did not set the port correctly
200  - add a new "ctdb scriptstatus" command that shows the status of the eventrscripts.
201 * Mon Mar 16 2009 : Version 1.0.74
202  - Fixes to AIX from C Cowan.
203  - Fixes to ctdb_diagnostics so we collect correct GPFS data
204  - Fixes to the net conf list command in ctdb_diagnostics
205  - Check the static-routes file IFF it exists in ctdb_diagnostics
206 * Wed Mar 4 2009 : Version 1.0.73
207  - Add possibility to disable the check of shares for NFS and Samba
208  - From Sumit Bose, fix dependencies so make -j works
209 * Wed Feb 18 2009 : Version 1.0.72
210  - Updates to test scripts by martin s
211  - Adding a COPYING file
212  - Use netstat to check for services and ports and fallback to netcat
213    only if netstat is unavailable.
214 * Mon Feb 2 2009 : Version 1.0.71
215  - Additional ipv6 fixes from Michael Adams
216 * Fri Jan 16 2009 : Version 1.0.70
217  - IPv6 support is completed. this is backward compatible with ipv4-only
218    systems. To use IPv6 with samba and ctdb you need current GIT of samba 3.3
219    or michael adams samba-ctdeb branch.
220  - Many enhancements to the build system and scripts to make it more SUSE
221    friendly by Michael Adams.
222  - Change of how the naming of the package is structured. We are now
223    using "1.0.70" as a release and "-1" as the revision instead of as
224    previously using "1.0" as release and ".70" as the revision.
225    By Michael Adams.
226 * Thu Dec 18 2008 : Version 1.0.69
227  - Various fixes to scripts by M Adam
228  - Dont call ctdb_fatal() when the transport is down during shutdown
229 * Fri Dec 12 2008 : Version 1.0.68
230  - Fixes for monitoring of interfaces status from Michael Adam.
231  - Use -q instead of >/dev/null for grep to enhance readability of the
232    scripts from Michael Adam.
233  - Update to the "ctdb recover" command. This command now block until the
234    has completed. This makes it much easier to use in scripts and avoids
235    the common workaround :
236       ctdb recover
237       ... loop while waiting for recovery completes ...
238       continue ...
239  - Add a CTDB_TIMEOUT variable. If set, this variable provides an automatic
240    timeout for "ctdb <command>", similar to using -T <timeout>
241  - Set a unique errorcode for "ctdb <command>" when it terminates due to a 
242    timeout so that scripts can distinguish between a hung command and what was
243    just a failure.
244  - Update "ctdb ban/unban" so that if the cluster is in recovery these commands
245    blocks and waits until after recovery is complete before the perform the
246    ban/unban operation. This is necessary since the recovery process can cause
247    nodes to become automatically unbanned.
248  - Update "ctdb ban/unban" to block until the recovery that will follow shortly
249    after this command has completed.
250    This makes it much easier to use in scripts and avoids the common
251    workaround :
252       ctdb ban/unban
253       ... loop while waiting for recovery completes ...
254       continue ...
255  - Bugfix for the new flags handling in 1.0.67. Abort and restart monitoring
256    if we failed to get proper nodemaps from a remote node instead of
257    dereferencing a null pointer.
258  - If ctdbd was explicitely started with the '--socket' argument, make
259    ctdbd automatically set CTDB_SOCKET to the specified argument.
260    This ensures that eventscripts spawned by the ctdb daemon will default to
261    using the same socket and talk to the correct daemon.
262    This primarily affects running multiple daemons on the same host and where 
263    you want each instance of ctdb daemons have their eventscripts talk to the
264    "correct" daemon.
265  - Update "ctdb ping" to return an error code if the ping fail so that it
266    can be used in scripts.
267  - Update to how to synchronize management of node flags across the cluster.
268 * Thu Dec 3 2008 : Version 1.0.67
269  - Add a document describing the recovery process.
270  - Fix a bug in "ctdb setdebug" where it would refuse to set a negative
271    debug level.
272  - Print the list of literals for debug names if an invalid one was given
273    to "ctdb setdebug"
274  - Redesign how "ctdb reloadnodes" works and reduce the amont of tcp teardowns
275    used during this event.
276  - Make it possible to delete a public ip from all nodes at once using
277    "ctdb delip -n all"
278 * Mon Nov 24 2008 : Version 1.0.66
279  - Allow to change the recmaster even when we are not frozen.
280  - Remove two redundant SAMBA_CHECK variables from the sysconf example
281  - After a node failure it can take very long before some lock operations
282    ctdb needs to perform are allowed/works with gpfs again. Workaround this
283    by treating a hang/timeout as success.
284  - Dont override CTDB_BASE is fet in the shell already
285  - Always send keepalive packets regardless of whether the link is idle or not.
286  - Rewrite the disable/enable flag update logic to prevent a race between 
287    "ctdb disable/enable" and the recovery daemon when updating the flags to 
288    all nodes.
289 * Thu Nov 13 2008 : Version 1.0.65
290  - Update the sysconfig example: The default debug level is 2 (NOTICE) and not
291    0 (ERROR)
292  - Add support for a CTDB_SOCKET environment variable for the ctdb command
293    line tool. If set, this overrides the default socket the ctdb tool will
294    use.
295  - Add logging of high latency operations.
296 * Mon Oct 22 2008 : Version 1.0.64
297  - Add a context and a timed event so that once we have been in recovery for
298    too long we drop all public addresses.
299 * Mon Oct 20 2008 : Version 1.0.63
300  - Remove logging of "periodic cleanup ..." in 50.samba
301  - When we reload a nodes file, we must detect this and reload the file also
302    in the recovery daemon before we try to dereference somethoung beyond the end
303    of the nodes array.
304 * Thu Oct 16 2008 : Version 1.0.62
305  - Allow multiple eventscritps using the same prefix number.
306    It is undefined which order scripts with the same prefix will execute in.
307 * Wed Oct 15 2008 : Version 1.0.61
308  - Use "route add -net" instead of "ip route add" when adding routes in 99.routing
309  - lower the loglevel os several debug statements
310  - check the status returned from ctdb_ctrl_get_tickles() before we try to print them out to the screen.
311  - install a new eventscript 20.multipathd whoich can be used to monitor that multipath devices are healthy
312 * Wed Oct 15 2008 : Version 1.0.60
313  - Verify that nodes we try to ban/unban are reachable and print an error othervise.
314  - Update the client and server sides of TAKEIP/RELEASEIP/GETPUBLICIPS and GETNODEMAP to fall back to the old style ipv4-only controls if the new ipv4/ipv6 controls fail. This allows an ipv4/v6 enabled ctdb daemon to interoperate with earlier ipv4-only versions of the daemons.
315  - From Mathieu Parent : log debian systems log the package versions in ctdb diagnostics
316  - From Mathieu Parent : specify logdir location for debian (this patch was later reversed)
317  - From Michael Adams : allow # comments in nodes/public_addresses files
318 * Tue Oct 7 2008 : Version 1.0.59
319  - Updated "reloadnodes" logic. Instead of bouncing the entire tcp layer it is sufficient to just close and reopen all outgoing tcp connections.
320  - New eventscript 99.routing which can be used to re-attach routes to public interfaces after a takeip event. (routes may be deleted by the kernel when we release an ip)
321  - IDR tree fix from Jim Houston
322  - Better handling of critical events if the local clock is suddenly changed forward by a lot.
323  - Fix three slow memory leaks in the recovery daemon
324  - New ctdb command : ctdb recmaster   which prints the pnn of the recmaster
325  - Onnode enhancements from Martin S : "healthy" and "connected" are now possible nodespecifiers
326  - From Martin S : doc fixes
327  - lowering some debug levels for some nonvital informational messages
328  - Make the daemon daemon monitoring stronger and allow ctdbd to detect a hung
329    recovery daemon.
330  - From C Cowan : patches to compile ipv6 under AIX
331  - zero out some structs to keep valgrind happy
332 * Wed Aug 27 2008 : Version 1.0.58
333  - revert the name change tcp_tcp_client back to tcp_control_tcp so
334    samba can build.
335  - Updates to the init script from Abhijith Das <adas@redhat.com>
336 * Mon Aug 25 2008 : Version 1.0.57
337  - initial support for IPv6
338 * Mon Aug 11 2008 : Version 1.0.56
339  - fix a memory leak in the recovery daemon.
340 * Mon Aug 11 2008 : Version 1.0.55
341  - Fix the releaseip message we seond to samba.
342 * Fri Aug 8 2008 : Version 1.0.54
343  - fix a looping error in the transaction code
344  - provide a more detailed error code for persistent store errors
345    so clients can make more intelligent choices on how to try to recover
346 * Thu Aug 7 2008 : Version 1.0.53
347  - Remove the reclock.pnn file   it can cause gpfs to fail to umount
348  - New transaction code
349 * Mon Aug 4 2008 : Version 1.0.52
350  - Send an explicit gratious arp when starting sending the tcp tickles.
351  - When doing failover, issue a killtcp to non-NFS/non-CIFS clients
352    so that they fail quickly. NFS and CIFS already fail and recover 
353    quickly.
354  - Update the test scripts to handle CTRL-C to kill off the test.
355 * Mon Jul 28 2008 : Version 1.0.51
356  - Strip off the vlan tag from bond devices before we check in /proc
357    if the interface is up or not.
358  - Use testparm in the background in the scripts to allow probing
359    that the shares do exist.
360  - Fix a bug in the logging code to handle multiline entries better
361  - Rename private elements from private to private_data
362 * Fri Jul 18 2008 : Version 1.0.50
363  - Dont assume that just because we can establish a TCP connection
364    that we are actually talking to a functioning ctdb daemon.
365    So dont mark the node as CONNECTED just because the tcp handshake
366    was successful.
367  - Dont try to set the recmaster to ourself during elections for those
368    cases we know this will fail. To remove some annoying benign but scary
369    looking entries from the log.
370  - Bugfix for eventsystem for signal handling that could cause a node to
371    hang.
372 * Thu Jul 17 2008 : Version 1.0.49
373  - Update the safe persistent update fix to work with unpatched samba
374    servers.
375 * Thu Jul 17 2008 : Version 1.0.48
376  - Update the spec file.
377  - Do not start new user-triggered eventscripts if we are already
378    inside recovery mode.
379  - Add two new controls to start/cancel a persistent update.
380    A client such as samba can use these to tell ctdbd that it will soon
381    be writing directly to the persistent database tdb file. So if
382    samba is -9ed before it has eitehr done the persistent_store or
383    canceled the operation, ctdb knows that the persistent databases
384    'may' be out of sync and therefore a full blown recovery is called for.
385  - Add two new options :
386    CTDB_SAMBA_SKIP_CONF_CHECK and CTDB_SAMBA_CHECK_PORTS that can be used
387    to override what checks to do when monitoring samba health.
388    We can no longer use the smbstatus, net or testparm commands to check
389    if samba or its config is healthy since these commands may block
390    indefinitely and thus can not be used in scripts.
391 * Fri Jul 11 2008 : Version 1.0.47
392  - Fix a double free bug where if a user striggered (ctdb eventscript)
393    hung and while the timeout handler was being processed a new user
394    triggered eventscript was started we would free state twice.
395  - Rewrite of onnode and associated documentation.
396 * Thu Jul 10 2008 : Version 1.0.46
397  - Document both the LVS:cingle-ip-address and the REMOTE-NODE:wan-accelerator
398    capabilities.
399  - Add commands "ctdb pnn", "ctdb lvs", "ctdb lvsmaster".
400  - LVS improvements. LVS is the single-ip-address mode for a ctdb cluster.
401  - Fixes to supress rpmlint warnings
402  - AXI compile fixes.
403  - Change \s to [[:space:]] in some scripts. Not all RHEL5 packages come
404    with a egrep that handles \s   even same version but different arch.
405  - Revert the change to NFS restart. CTDB should NOT attempt to restart
406    failed services.
407  - Rewrite of the waitpid() patch to use the eventsystem for handling
408    signals.
409 * Tue Jul 8 2008 : Version 1.0.45
410  - Try to restart the nfs service if it has failed to respond 3 times in a row.
411  - waitpid() can block if the child does not respond promptly to SIGTERM.
412    ignore all SIGCHILD signals by setting SIGCHLD to SIG_DEF.
413    get rid of all calls to waitpid().
414  - make handling of eventscripts hanging more liberal.
415    only consider the script to have failed and making the node unhealthy
416    IF the eventscript terminated wiht an error
417    OR the eventscript hung 5 or more times in a row
418 * Mon Jul 7 2008 : Version 1.0.44
419  - Add a CTDB_VALGRIND option to /etc/sysconfig/ctdb to make it start
420    ctdb under valgrind. Logs go to /var/log/ctdb_valgrind.PID
421  - Add a hack to show the control opcode that caused uninitialized data
422    in the valgrind output by encoding the opcode as the line number.
423  - Initialize structures and allocated memory in various places in
424    ctdb to make it valgrind-clean and remove all valgrind errors/warnings.
425  - If/when we destroy a lockwait child, also make sure we cancel any pending transactions
426  - If a transaction_commit fails, delete/cancel any pending transactions and
427    return an error instead of calling ctdb_fatal()
428  - When running ctdb under valgrind, make sure we run it with --nosetsched and also
429    ensure that we do not use mem-mapped i/o when accessing the tdb's.
430  - zero out ctdb->freeze_handle when we free/destroy a freeze-child.
431    This prevent a heap corruption/ctdb crash bug that could trigger
432    if the freeze child times out.
433  - we dont need to explicitely thaw the databases from the recovery daemon
434    since this is done implicitely when we restore the recovery mode back to normal.
435  - track when we start and stop a recovery. Add the 'time it took to complete the
436    recovery' to the 'ctdb uptime' output.
437    Ensure by tracking the start/stop recovery timestamps that we do not
438    check that the ip allocation is consistend from inside the recovery daemon
439    while a different node (recovery master) is performing a recovery.
440    This prevent a race that could cause a full recovery to trigger if the
441    'ctdb disable/enable' commands took very long.
442  - The freeze child indicates to the master daemon that all databases are locked
443    by writing data to the pipe shared with the master daemon.
444    This write sometimes fail and thus the master daemon never notices that the databases
445    are locked cvausing long timeouts and extra recoveries.
446    Check that the write is successful and try the write again if it failed.
447  - In each node, verify that the recmaster have the right node flags for us
448    and force a push of our flags to the recmaster if wrong.
449 * Tue Jul 1 2008 : Version 1.0.43
450  - Updates and bugfixes to the specfile to keep rpmlint happy
451  - Force a global flags update after each recovery event.
452  - Verify that the recmaster agrees with our node flags and update the
453    recmaster othervise.
454  - When writing back to the parent from a freeze-child across the pipe,
455    loop over the write in case the write failed with an error  othervise
456    the parent will never be notified tha the child has completed the operation.
457  - Automatically thaw all databases when recmaster marks us as being in normal
458    mode instead of recovery mode.
459 * Fri Jun 13 2008 : Version 1.0.42
460  - When event scripts have hung/timedout more than EventScriptBanCount times
461    in a row the node will ban itself.
462  - Many updates to persistent write tests and the test scripts.
463 * Wed May 28 2008 : Version 1.0.41
464  - Reactivate the safe writes to persistent databases and solve the
465    locking issues. Locking issues are solved the only possible way,
466    by using a child process to do the writes.  Expensive and slow but... . 
467 * Tue May 27 2008 : Version 1.0.40
468  - Read the samba sysconfig file from the 50.samba eventscript
469  - Fix some emmory hierarchical bugs in the persistent write handling
470 * Thu May 22 2008 : Version 1.0.39
471  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
472    into /etc/sysconfig/ctdb
473  - Lowered some debug messages to not fill the logfile with entries
474    that normally occur in the default configuration.
475 * Fri May 16 2008 : Version 1.0.38
476  - Add machine readable output support to "ctdb getmonmode"
477  - Lots of tweaks and enhancements if the event scripts are "slow"
478  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
479    net conf introduces if used from an eventscript.
480  - Enhance tickles so we can tickle an ipv6 connection.
481  - Start adding ipv6 support : create a new container to replace sockaddr_in.
482  - Add a checksum routine for ipv6/tcp
483  - When starting up ctdb, let the init script do a tdbdump on all
484    persistent databases and verify that they are good (i.e. not corrupted).
485  - Try to use "safe transactions" when writing to a persistent database
486    that was opened with the TDB_NOSYNC flag. If we can get the transaction
487    thats great, if we cant  we have to write anyway since we cant block here.
488 * Mon May 12 2008 : Version 1.0.37
489  - When we shutdown ctdb we close the transport down before we run the 
490    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
491    after we have shutdown the transport but before we have shutdown ctdbd
492    itself this could lead to a SEGV instead of a clean shutdown. Fix.
493  - When using the "exportfs" command to extract which NFS export directories
494    to monitor,  exportfs violates the "principle of least surprise" and
495    sometimes report a single export line as two lines of text output
496    causing the monitoring to fail.
497 * Fri May 9 2008 : Version 1.0.36
498  - fix a memory corruption bug that could cause the recovery daemon to crash.
499  - fix a bug with distributing public ip addresses during recovery.
500    If the node that is the recovery master did NOT use public addresses,
501    then it assumed that no other node in the cluster used them either and
502    thus skipped the entire step of reallocating public addresses.
503 * Wed May 7 2008 : Version 1.0.35
504  - During recovery, when we define the new set of lmasters (vnnmap)
505    only consider those nodes that have the can-be-lmaster capability
506    when we create the vnnmap. unless there are no nodes available which
507    supports this capability in which case we allow the recmaster to
508    become lmaster capable (temporarily).
509  - Extend the async framework so that we can use paralell async calls
510    to controls that return data.
511  - If we do not have the "can be recmaster" capability, make sure we will
512    lose any recmaster elections, unless there are no nodes available that
513    have the capability, in which case we "take/win" the election anyway.
514  - Close and reopen the reclock pnn file at regular intervals.
515    Make it a non-fatal event if we occasionally fail to open/read/write
516    to this file.
517  - Monitor that the recovery daemon is still running from the main ctdb
518    daemon and shutdown the main daemon when recovery daemon has terminated.
519  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
520  - Define two new capabilities : can be recmaster and can be lmaster
521    and default both capabilities to YES.
522  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
523 * Thu Apr 24 2008 : Version 1.0.34
524  - When deleting a public ip from a node, try to migrate the ip to a different
525    node first.
526  - Change catdb to produce output similar to tdbdump
527  - When adding a new public ip address, if this ip does not exist yet in
528    the cluster, then grab the ip on the local node and activate it.
529  - When a node disagrees with the recmaster on WHO is the recmaster, then
530    mark that node as a recovery culprit so it will eventually become
531    banned.
532  - Make ctdb eventscript support the -n all argument.
533 * Thu Apr 10 2008 : Version 1.0.33
534  - Add facilities to include site local adaptations to the eventscript
535    by /etc/ctdb/rc.local which will be read by all eventscripts.
536  - Add a "ctdb version" command.
537  - Secure the domain socket with proper permissions from Chris Cowan
538  - Bugfixes for AIX from Chris Cowan
539 * Wed Apr 02 2008 : Version 1.0.32
540  - Add a control to have a node execute the eventscripts with arbitrary
541    command line arguments.
542  - Add a control "rddumpmemory" that will dump the talloc memory allocations
543    for the recovery daemon.
544  - Decorate the talloc memdump to produce better and easier memory leak
545    tracking. 
546  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
547    public address.
548  - Add two new controls "addip/delip" that can be used to add/remove public
549    addresses to a node at runtime. After using these controls a "ctdb recover"
550    ir required to make the changes take.
551  - Fix a couple of slow memory leaks.
552 * Tue Mar 25 2008 : Version 1.0.31
553  - Add back controls to disable/enable monitoring on a node.
554  - Fix a memory leak where we used to attach CALL data to the ctdb structure
555    when performing a local call. Memory which would be lost if the call was
556    aborted.
557  - Reduce the loglevel for the log output when someone connects to a non
558    public ip address for samba.
559  - Redo and optimize the vacuuming process to send only one control to each
560    other node containing all records to be vacuumed instead of one
561    control per node per record.
562 * Tue Mar 04 2008 : Version 1.0.30
563  - Update documentation cor new commands and tuneables
564  - Add machinereadable output to the ip,uptime and getdebug commands
565  - Add a moveip command to manually failover/failback public ips
566  - Add NoIPFallback tuneable that prevents ip address failback
567  - Use file locking inside the CFS as alternative to verify when other nodes
568    Are connected/disconnected to be able to recover from split network
569  - Add DisableWhenUnhealthy tunable
570  - Add CTDB_START_AS_DISABLED sysconfig param
571  - Add --start-as-disabled flag to ctdb
572  - Add ability to monitor for OOM condition
573 * Thu Feb 21 2008 : Version 1.0.29
574  - Add a new command to make expansion of an existing cluster easier
575  - Fix bug with references to freed objects in the ctdb structure
576  - Propagate debuglevel changes to the recovery daemon
577  - Merge patches to event scripts from Mathieu Parent :
578  - MP: Simulate "service" on systems which do not provide this tool
579  - MP: Set correct permissions for events.d/README
580  - Add nice helper functions to start/stop nfs from the event scripts
581 * Fri Feb 08 2008 : Version 1.0.28
582  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
583  - Warn if the ipvsadm packege is missing when LVS is used
584  - Dont use absolute pathnames in some of the event scripts
585  - Fix for persistent tdbs growing inifinitely.
586 * Wed Feb 06 2008 : Version 1.0.27
587  - Add eventscript for iscsi
588 * Thu Jan 31 2008 : Version 1.0.26
589  - Fix crashbug in tdb transaction code
590 * Tue Jan 29 2008 : Version 1.0.25
591  - added async recovery code
592  - make event scripts more portable
593  - fixed ctdb dumpmemory
594  - more efficient tdb allocation code
595  - improved machine readable ctdb status output
596  - added ctdb uptime
597 * Wed Jan 16 2008 : Version 1.0.24
598  - added syslog support
599  - documentation updates
600 * Wed Jan 16 2008 : Version 1.0.23
601  - fixed a memory leak in the recoveryd
602  - fixed a corruption bug in the new transaction code
603  - fixed a case where an packet for a disconnected client could be processed
604  - added http event script
605  - updated documentation
606 * Thu Jan 10 2008 : Version 1.0.22
607  - auto-run vacuum and repack ops
608 * Wed Jan 09 2008 : Version 1.0.21
609  - added ctdb vacuum and ctdb repack code
610 * Sun Jan 06 2008 : Version 1.0.20
611  - new transaction based recovery code
612 * Sat Jan 05 2008 : Version 1.0.19
613  - fixed non-master bug
614  - big speedup in recovery for large databases
615  - lots of changes to improve tdb and ctdb for high churn databases
616 * Thu Dec 27 2007 : Version 1.0.18
617  - fixed crash bug in monitor_handler
618 * Tue Dec 04 2007 : Version 1.0.17
619  - fixed bugs related to ban/unban of nodes
620  - fixed a race condition that could lead to monitoring being permanently disabled,
621    which would lead to long recovery times
622  - make deterministic IPs the default
623  - fixed a bug related to continuous recovery 
624  - added a debugging option --node-ip