432a6aab7ef65c965c42852244b681d0458afc4a
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0
8 Release: 69_5
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 CC="gcc"
38
39 ## always run autogen.sh
40 ./autogen.sh
41
42 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
43         --prefix=%{_prefix} \
44         --sysconfdir=%{_sysconfdir} \
45         --mandir=%{_mandir} \
46         --localstatedir="/var"
47
48 make docdir=%{_docdir} showflags
49 make docdir=%{_docdir}
50
51 %install
52 # Clean up in case there is trash left from a previous build
53 rm -rf $RPM_BUILD_ROOT
54
55 # Create the target build directory hierarchy
56 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
57 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
58
59 make DESTDIR=$RPM_BUILD_ROOT docdir=%{_docdir} install
60
61 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
62 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
63
64 # Remove "*.old" files
65 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
72
73 %preun
74 if [ $1 = 0 ] ; then
75     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
76 fi
77 exit 0
78
79 %postun
80 if [ "$1" -ge "1" ]; then
81         %{initdir}/ctdb restart >/dev/null 2>&1 || true
82 fi      
83
84
85 #######################################################################
86 ## Files section                                                     ##
87 #######################################################################
88
89 %files
90 %defattr(-,root,root)
91
92 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
93 %config(noreplace) %{_sysconfdir}/ctdb/functions
94 %attr(755,root,root) %{initdir}/ctdb
95
96 %{_docdir}/ctdb/README.eventscripts
97 %{_docdir}/ctdb/recovery-process.txt
98 %{_sysconfdir}/ctdb/events.d/00.ctdb
99 %{_sysconfdir}/ctdb/events.d/10.interface
100 %{_sysconfdir}/ctdb/events.d/20.multipathd
101 %{_sysconfdir}/ctdb/events.d/40.vsftpd
102 %{_sysconfdir}/ctdb/events.d/41.httpd
103 %{_sysconfdir}/ctdb/events.d/50.samba
104 %{_sysconfdir}/ctdb/events.d/60.nfs
105 %{_sysconfdir}/ctdb/events.d/61.nfstickle
106 %{_sysconfdir}/ctdb/events.d/70.iscsi
107 %{_sysconfdir}/ctdb/events.d/90.ipmux
108 %{_sysconfdir}/ctdb/events.d/91.lvs
109 %{_sysconfdir}/ctdb/events.d/99.routing
110 %{_sysconfdir}/ctdb/statd-callout
111 %{_sbindir}/ctdbd
112 %{_bindir}/ctdb
113 %{_bindir}/smnotify
114 %{_bindir}/ctdb_ipmux
115 %{_bindir}/ctdb_diagnostics
116 %{_bindir}/onnode
117 %{_mandir}/man1/ctdb.1.gz
118 %{_mandir}/man1/ctdbd.1.gz
119 %{_mandir}/man1/onnode.1.gz
120 %{_includedir}/ctdb.h
121 %{_includedir}/ctdb_private.h
122
123 %changelog
124 * Fri May 1 2009 : Version 1.0.69-5
125  - Add a new variable VerifyRecoveryLock. When set to 0 this will skip
126    the test inside the main where it verifies that the recovery masted does
127    hold the lock to the reclock file while performing a recovery.
128  - Change the timeout for waiting for a reclock child process to terminate to
129    15 seconds and increase the logging of this potentially fatal condition.
130 * Sun Apr 26 2009 : Version 1.0.69_4
131  - Add TDB_NO_NESTING to the tdb layer to prevent transaction nesting.
132  - Make sure that when we start a recovery transaction that this is not a
133    nested transaction.
134  - Add a tuneable RecoveryDropAllIPs that specifies after how long being in
135    recovery mode a node will elect to drop all its public addresses.
136 * Fri Apr 24 2009 : Version 1.0.69_3
137  - Make sure that if during recovery a node is stuck and does not reply to
138    pull_db requests that we eventually ban this node from the recovery master.
139 * Thu Apr 23 2009 : Version 1.0.69_2
140  - In the recovery daemon we dont need to check the nodemap status
141    of banned nodes.
142 * Wed Feb 5 2009 : Version 1.0.69_1
143  - Dont check the result of the modflags control, to allow compatibility
144    with earlier versions of ctdb
145 * Thu Dec 18 2008 : Version 1.0.69
146  - Various fixes to scripts by M Adam
147  - Dont call ctdb_fatal() when the transport is down during shutdown
148 * Fri Dec 12 2008 : Version 1.0.68
149  - Fixes for monitoring of interfaces status from Michael Adam.
150  - Use -q instead of >/dev/null for grep to enhance readability of the
151    scripts from Michael Adam.
152  - Update to the "ctdb recover" command. This command now block until the
153    has completed. This makes it much easier to use in scripts and avoids
154    the common workaround :
155       ctdb recover
156       ... loop while waiting for recovery completes ...
157       continue ...
158  - Add a CTDB_TIMEOUT variable. If set, this variable provides an automatic
159    timeout for "ctdb <command>", similar to using -T <timeout>
160  - Set a unique errorcode for "ctdb <command>" when it terminates due to a 
161    timeout so that scripts can distinguish between a hung command and what was
162    just a failure.
163  - Update "ctdb ban/unban" so that if the cluster is in recovery these commands
164    blocks and waits until after recovery is complete before the perform the
165    ban/unban operation. This is necessary since the recovery process can cause
166    nodes to become automatically unbanned.
167  - Update "ctdb ban/unban" to block until the recovery that will follow shortly
168    after this command has completed.
169    This makes it much easier to use in scripts and avoids the common
170    workaround :
171       ctdb ban/unban
172       ... loop while waiting for recovery completes ...
173       continue ...
174  - Bugfix for the new flags handling in 1.0.67. Abort and restart monitoring
175    if we failed to get proper nodemaps from a remote node instead of
176    dereferencing a null pointer.
177  - If ctdbd was explicitely started with the '--socket' argument, make
178    ctdbd automatically set CTDB_SOCKET to the specified argument.
179    This ensures that eventscripts spawned by the ctdb daemon will default to
180    using the same socket and talk to the correct daemon.
181    This primarily affects running multiple daemons on the same host and where 
182    you want each instance of ctdb daemons have their eventscripts talk to the
183    "correct" daemon.
184  - Update "ctdb ping" to return an error code if the ping fail so that it
185    can be used in scripts.
186  - Update to how to synchronize management of node flags across the cluster.
187 * Thu Dec 3 2008 : Version 1.0.67
188  - Add a document describing the recovery process.
189  - Fix a bug in "ctdb setdebug" where it would refuse to set a negative
190    debug level.
191  - Print the list of literals for debug names if an invalid one was given
192    to "ctdb setdebug"
193  - Redesign how "ctdb reloadnodes" works and reduce the amont of tcp teardowns
194    used during this event.
195  - Make it possible to delete a public ip from all nodes at once using
196    "ctdb delip -n all"
197 * Mon Nov 24 2008 : Version 1.0.66
198  - Allow to change the recmaster even when we are not frozen.
199  - Remove two redundant SAMBA_CHECK variables from the sysconf example
200  - After a node failure it can take very long before some lock operations
201    ctdb needs to perform are allowed/works with gpfs again. Workaround this
202    by treating a hang/timeout as success.
203  - Dont override CTDB_BASE is fet in the shell already
204  - Always send keepalive packets regardless of whether the link is idle or not.
205  - Rewrite the disable/enable flag update logic to prevent a race between 
206    "ctdb disable/enable" and the recovery daemon when updating the flags to 
207    all nodes.
208 * Thu Nov 13 2008 : Version 1.0.65
209  - Update the sysconfig example: The default debug level is 2 (NOTICE) and not
210    0 (ERROR)
211  - Add support for a CTDB_SOCKET environment variable for the ctdb command
212    line tool. If set, this overrides the default socket the ctdb tool will
213    use.
214  - Add logging of high latency operations.
215 * Mon Oct 22 2008 : Version 1.0.64
216  - Add a context and a timed event so that once we have been in recovery for
217    too long we drop all public addresses.
218 * Mon Oct 20 2008 : Version 1.0.63
219  - Remove logging of "periodic cleanup ..." in 50.samba
220  - When we reload a nodes file, we must detect this and reload the file also
221    in the recovery daemon before we try to dereference somethoung beyond the end
222    of the nodes array.
223 * Thu Oct 16 2008 : Version 1.0.62
224  - Allow multiple eventscritps using the same prefix number.
225    It is undefined which order scripts with the same prefix will execute in.
226 * Wed Oct 15 2008 : Version 1.0.61
227  - Use "route add -net" instead of "ip route add" when adding routes in 99.routing
228  - lower the loglevel os several debug statements
229  - check the status returned from ctdb_ctrl_get_tickles() before we try to print them out to the screen.
230  - install a new eventscript 20.multipathd whoich can be used to monitor that multipath devices are healthy
231 * Wed Oct 15 2008 : Version 1.0.60
232  - Verify that nodes we try to ban/unban are reachable and print an error othervise.
233  - Update the client and server sides of TAKEIP/RELEASEIP/GETPUBLICIPS and GETNODEMAP to fall back to the old style ipv4-only controls if the new ipv4/ipv6 controls fail. This allows an ipv4/v6 enabled ctdb daemon to interoperate with earlier ipv4-only versions of the daemons.
234  - From Mathieu Parent : log debian systems log the package versions in ctdb diagnostics
235  - From Mathieu Parent : specify logdir location for debian (this patch was later reversed)
236  - From Michael Adams : allow # comments in nodes/public_addresses files
237 * Tue Oct 7 2008 : Version 1.0.59
238  - Updated "reloadnodes" logic. Instead of bouncing the entire tcp layer it is sufficient to just close and reopen all outgoing tcp connections.
239  - New eventscript 99.routing which can be used to re-attach routes to public interfaces after a takeip event. (routes may be deleted by the kernel when we release an ip)
240  - IDR tree fix from Jim Houston
241  - Better handling of critical events if the local clock is suddenly changed forward by a lot.
242  - Fix three slow memory leaks in the recovery daemon
243  - New ctdb command : ctdb recmaster   which prints the pnn of the recmaster
244  - Onnode enhancements from Martin S : "healthy" and "connected" are now possible nodespecifiers
245  - From Martin S : doc fixes
246  - lowering some debug levels for some nonvital informational messages
247  - Make the daemon daemon monitoring stronger and allow ctdbd to detect a hung
248    recovery daemon.
249  - From C Cowan : patches to compile ipv6 under AIX
250  - zero out some structs to keep valgrind happy
251 * Wed Aug 27 2008 : Version 1.0.58
252  - revert the name change tcp_tcp_client back to tcp_control_tcp so
253    samba can build.
254  - Updates to the init script from Abhijith Das <adas@redhat.com>
255 * Mon Aug 25 2008 : Version 1.0.57
256  - initial support for IPv6
257 * Mon Aug 11 2008 : Version 1.0.56
258  - fix a memory leak in the recovery daemon.
259 * Mon Aug 11 2008 : Version 1.0.55
260  - Fix the releaseip message we seond to samba.
261 * Fri Aug 8 2008 : Version 1.0.54
262  - fix a looping error in the transaction code
263  - provide a more detailed error code for persistent store errors
264    so clients can make more intelligent choices on how to try to recover
265 * Thu Aug 7 2008 : Version 1.0.53
266  - Remove the reclock.pnn file   it can cause gpfs to fail to umount
267  - New transaction code
268 * Mon Aug 4 2008 : Version 1.0.52
269  - Send an explicit gratious arp when starting sending the tcp tickles.
270  - When doing failover, issue a killtcp to non-NFS/non-CIFS clients
271    so that they fail quickly. NFS and CIFS already fail and recover 
272    quickly.
273  - Update the test scripts to handle CTRL-C to kill off the test.
274 * Mon Jul 28 2008 : Version 1.0.51
275  - Strip off the vlan tag from bond devices before we check in /proc
276    if the interface is up or not.
277  - Use testparm in the background in the scripts to allow probing
278    that the shares do exist.
279  - Fix a bug in the logging code to handle multiline entries better
280  - Rename private elements from private to private_data
281 * Fri Jul 18 2008 : Version 1.0.50
282  - Dont assume that just because we can establish a TCP connection
283    that we are actually talking to a functioning ctdb daemon.
284    So dont mark the node as CONNECTED just because the tcp handshake
285    was successful.
286  - Dont try to set the recmaster to ourself during elections for those
287    cases we know this will fail. To remove some annoying benign but scary
288    looking entries from the log.
289  - Bugfix for eventsystem for signal handling that could cause a node to
290    hang.
291 * Thu Jul 17 2008 : Version 1.0.49
292  - Update the safe persistent update fix to work with unpatched samba
293    servers.
294 * Thu Jul 17 2008 : Version 1.0.48
295  - Update the spec file.
296  - Do not start new user-triggered eventscripts if we are already
297    inside recovery mode.
298  - Add two new controls to start/cancel a persistent update.
299    A client such as samba can use these to tell ctdbd that it will soon
300    be writing directly to the persistent database tdb file. So if
301    samba is -9ed before it has eitehr done the persistent_store or
302    canceled the operation, ctdb knows that the persistent databases
303    'may' be out of sync and therefore a full blown recovery is called for.
304  - Add two new options :
305    CTDB_SAMBA_SKIP_CONF_CHECK and CTDB_SAMBA_CHECK_PORTS that can be used
306    to override what checks to do when monitoring samba health.
307    We can no longer use the smbstatus, net or testparm commands to check
308    if samba or its config is healthy since these commands may block
309    indefinitely and thus can not be used in scripts.
310 * Fri Jul 11 2008 : Version 1.0.47
311  - Fix a double free bug where if a user striggered (ctdb eventscript)
312    hung and while the timeout handler was being processed a new user
313    triggered eventscript was started we would free state twice.
314  - Rewrite of onnode and associated documentation.
315 * Thu Jul 10 2008 : Version 1.0.46
316  - Document both the LVS:cingle-ip-address and the REMOTE-NODE:wan-accelerator
317    capabilities.
318  - Add commands "ctdb pnn", "ctdb lvs", "ctdb lvsmaster".
319  - LVS improvements. LVS is the single-ip-address mode for a ctdb cluster.
320  - Fixes to supress rpmlint warnings
321  - AXI compile fixes.
322  - Change \s to [[:space:]] in some scripts. Not all RHEL5 packages come
323    with a egrep that handles \s   even same version but different arch.
324  - Revert the change to NFS restart. CTDB should NOT attempt to restart
325    failed services.
326  - Rewrite of the waitpid() patch to use the eventsystem for handling
327    signals.
328 * Tue Jul 8 2008 : Version 1.0.45
329  - Try to restart the nfs service if it has failed to respond 3 times in a row.
330  - waitpid() can block if the child does not respond promptly to SIGTERM.
331    ignore all SIGCHILD signals by setting SIGCHLD to SIG_DEF.
332    get rid of all calls to waitpid().
333  - make handling of eventscripts hanging more liberal.
334    only consider the script to have failed and making the node unhealthy
335    IF the eventscript terminated wiht an error
336    OR the eventscript hung 5 or more times in a row
337 * Mon Jul 7 2008 : Version 1.0.44
338  - Add a CTDB_VALGRIND option to /etc/sysconfig/ctdb to make it start
339    ctdb under valgrind. Logs go to /var/log/ctdb_valgrind.PID
340  - Add a hack to show the control opcode that caused uninitialized data
341    in the valgrind output by encoding the opcode as the line number.
342  - Initialize structures and allocated memory in various places in
343    ctdb to make it valgrind-clean and remove all valgrind errors/warnings.
344  - If/when we destroy a lockwait child, also make sure we cancel any pending transactions
345  - If a transaction_commit fails, delete/cancel any pending transactions and
346    return an error instead of calling ctdb_fatal()
347  - When running ctdb under valgrind, make sure we run it with --nosetsched and also
348    ensure that we do not use mem-mapped i/o when accessing the tdb's.
349  - zero out ctdb->freeze_handle when we free/destroy a freeze-child.
350    This prevent a heap corruption/ctdb crash bug that could trigger
351    if the freeze child times out.
352  - we dont need to explicitely thaw the databases from the recovery daemon
353    since this is done implicitely when we restore the recovery mode back to normal.
354  - track when we start and stop a recovery. Add the 'time it took to complete the
355    recovery' to the 'ctdb uptime' output.
356    Ensure by tracking the start/stop recovery timestamps that we do not
357    check that the ip allocation is consistend from inside the recovery daemon
358    while a different node (recovery master) is performing a recovery.
359    This prevent a race that could cause a full recovery to trigger if the
360    'ctdb disable/enable' commands took very long.
361  - The freeze child indicates to the master daemon that all databases are locked
362    by writing data to the pipe shared with the master daemon.
363    This write sometimes fail and thus the master daemon never notices that the databases
364    are locked cvausing long timeouts and extra recoveries.
365    Check that the write is successful and try the write again if it failed.
366  - In each node, verify that the recmaster have the right node flags for us
367    and force a push of our flags to the recmaster if wrong.
368 * Tue Jul 1 2008 : Version 1.0.43
369  - Updates and bugfixes to the specfile to keep rpmlint happy
370  - Force a global flags update after each recovery event.
371  - Verify that the recmaster agrees with our node flags and update the
372    recmaster othervise.
373  - When writing back to the parent from a freeze-child across the pipe,
374    loop over the write in case the write failed with an error  othervise
375    the parent will never be notified tha the child has completed the operation.
376  - Automatically thaw all databases when recmaster marks us as being in normal
377    mode instead of recovery mode.
378 * Fri Jun 13 2008 : Version 1.0.42
379  - When event scripts have hung/timedout more than EventScriptBanCount times
380    in a row the node will ban itself.
381  - Many updates to persistent write tests and the test scripts.
382 * Wed May 28 2008 : Version 1.0.41
383  - Reactivate the safe writes to persistent databases and solve the
384    locking issues. Locking issues are solved the only possible way,
385    by using a child process to do the writes.  Expensive and slow but... . 
386 * Tue May 27 2008 : Version 1.0.40
387  - Read the samba sysconfig file from the 50.samba eventscript
388  - Fix some emmory hierarchical bugs in the persistent write handling
389 * Thu May 22 2008 : Version 1.0.39
390  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
391    into /etc/sysconfig/ctdb
392  - Lowered some debug messages to not fill the logfile with entries
393    that normally occur in the default configuration.
394 * Fri May 16 2008 : Version 1.0.38
395  - Add machine readable output support to "ctdb getmonmode"
396  - Lots of tweaks and enhancements if the event scripts are "slow"
397  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
398    net conf introduces if used from an eventscript.
399  - Enhance tickles so we can tickle an ipv6 connection.
400  - Start adding ipv6 support : create a new container to replace sockaddr_in.
401  - Add a checksum routine for ipv6/tcp
402  - When starting up ctdb, let the init script do a tdbdump on all
403    persistent databases and verify that they are good (i.e. not corrupted).
404  - Try to use "safe transactions" when writing to a persistent database
405    that was opened with the TDB_NOSYNC flag. If we can get the transaction
406    thats great, if we cant  we have to write anyway since we cant block here.
407 * Mon May 12 2008 : Version 1.0.37
408  - When we shutdown ctdb we close the transport down before we run the 
409    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
410    after we have shutdown the transport but before we have shutdown ctdbd
411    itself this could lead to a SEGV instead of a clean shutdown. Fix.
412  - When using the "exportfs" command to extract which NFS export directories
413    to monitor,  exportfs violates the "principle of least surprise" and
414    sometimes report a single export line as two lines of text output
415    causing the monitoring to fail.
416 * Fri May 9 2008 : Version 1.0.36
417  - fix a memory corruption bug that could cause the recovery daemon to crash.
418  - fix a bug with distributing public ip addresses during recovery.
419    If the node that is the recovery master did NOT use public addresses,
420    then it assumed that no other node in the cluster used them either and
421    thus skipped the entire step of reallocating public addresses.
422 * Wed May 7 2008 : Version 1.0.35
423  - During recovery, when we define the new set of lmasters (vnnmap)
424    only consider those nodes that have the can-be-lmaster capability
425    when we create the vnnmap. unless there are no nodes available which
426    supports this capability in which case we allow the recmaster to
427    become lmaster capable (temporarily).
428  - Extend the async framework so that we can use paralell async calls
429    to controls that return data.
430  - If we do not have the "can be recmaster" capability, make sure we will
431    lose any recmaster elections, unless there are no nodes available that
432    have the capability, in which case we "take/win" the election anyway.
433  - Close and reopen the reclock pnn file at regular intervals.
434    Make it a non-fatal event if we occasionally fail to open/read/write
435    to this file.
436  - Monitor that the recovery daemon is still running from the main ctdb
437    daemon and shutdown the main daemon when recovery daemon has terminated.
438  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
439  - Define two new capabilities : can be recmaster and can be lmaster
440    and default both capabilities to YES.
441  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
442 * Thu Apr 24 2008 : Version 1.0.34
443  - When deleting a public ip from a node, try to migrate the ip to a different
444    node first.
445  - Change catdb to produce output similar to tdbdump
446  - When adding a new public ip address, if this ip does not exist yet in
447    the cluster, then grab the ip on the local node and activate it.
448  - When a node disagrees with the recmaster on WHO is the recmaster, then
449    mark that node as a recovery culprit so it will eventually become
450    banned.
451  - Make ctdb eventscript support the -n all argument.
452 * Thu Apr 10 2008 : Version 1.0.33
453  - Add facilities to include site local adaptations to the eventscript
454    by /etc/ctdb/rc.local which will be read by all eventscripts.
455  - Add a "ctdb version" command.
456  - Secure the domain socket with proper permissions from Chris Cowan
457  - Bugfixes for AIX from Chris Cowan
458 * Wed Apr 02 2008 : Version 1.0.32
459  - Add a control to have a node execute the eventscripts with arbitrary
460    command line arguments.
461  - Add a control "rddumpmemory" that will dump the talloc memory allocations
462    for the recovery daemon.
463  - Decorate the talloc memdump to produce better and easier memory leak
464    tracking. 
465  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
466    public address.
467  - Add two new controls "addip/delip" that can be used to add/remove public
468    addresses to a node at runtime. After using these controls a "ctdb recover"
469    ir required to make the changes take.
470  - Fix a couple of slow memory leaks.
471 * Tue Mar 25 2008 : Version 1.0.31
472  - Add back controls to disable/enable monitoring on a node.
473  - Fix a memory leak where we used to attach CALL data to the ctdb structure
474    when performing a local call. Memory which would be lost if the call was
475    aborted.
476  - Reduce the loglevel for the log output when someone connects to a non
477    public ip address for samba.
478  - Redo and optimize the vacuuming process to send only one control to each
479    other node containing all records to be vacuumed instead of one
480    control per node per record.
481 * Tue Mar 04 2008 : Version 1.0.30
482  - Update documentation cor new commands and tuneables
483  - Add machinereadable output to the ip,uptime and getdebug commands
484  - Add a moveip command to manually failover/failback public ips
485  - Add NoIPFallback tuneable that prevents ip address failback
486  - Use file locking inside the CFS as alternative to verify when other nodes
487    Are connected/disconnected to be able to recover from split network
488  - Add DisableWhenUnhealthy tunable
489  - Add CTDB_START_AS_DISABLED sysconfig param
490  - Add --start-as-disabled flag to ctdb
491  - Add ability to monitor for OOM condition
492 * Thu Feb 21 2008 : Version 1.0.29
493  - Add a new command to make expansion of an existing cluster easier
494  - Fix bug with references to freed objects in the ctdb structure
495  - Propagate debuglevel changes to the recovery daemon
496  - Merge patches to event scripts from Mathieu Parent :
497  - MP: Simulate "service" on systems which do not provide this tool
498  - MP: Set correct permissions for events.d/README
499  - Add nice helper functions to start/stop nfs from the event scripts
500 * Fri Feb 08 2008 : Version 1.0.28
501  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
502  - Warn if the ipvsadm packege is missing when LVS is used
503  - Dont use absolute pathnames in some of the event scripts
504  - Fix for persistent tdbs growing inifinitely.
505 * Wed Feb 06 2008 : Version 1.0.27
506  - Add eventscript for iscsi
507 * Thu Jan 31 2008 : Version 1.0.26
508  - Fix crashbug in tdb transaction code
509 * Tue Jan 29 2008 : Version 1.0.25
510  - added async recovery code
511  - make event scripts more portable
512  - fixed ctdb dumpmemory
513  - more efficient tdb allocation code
514  - improved machine readable ctdb status output
515  - added ctdb uptime
516 * Wed Jan 16 2008 : Version 1.0.24
517  - added syslog support
518  - documentation updates
519 * Wed Jan 16 2008 : Version 1.0.23
520  - fixed a memory leak in the recoveryd
521  - fixed a corruption bug in the new transaction code
522  - fixed a case where an packet for a disconnected client could be processed
523  - added http event script
524  - updated documentation
525 * Thu Jan 10 2008 : Version 1.0.22
526  - auto-run vacuum and repack ops
527 * Wed Jan 09 2008 : Version 1.0.21
528  - added ctdb vacuum and ctdb repack code
529 * Sun Jan 06 2008 : Version 1.0.20
530  - new transaction based recovery code
531 * Sat Jan 05 2008 : Version 1.0.19
532  - fixed non-master bug
533  - big speedup in recovery for large databases
534  - lots of changes to improve tdb and ctdb for high churn databases
535 * Thu Dec 27 2007 : Version 1.0.18
536  - fixed crash bug in monitor_handler
537 * Tue Dec 04 2007 : Version 1.0.17
538  - fixed bugs related to ban/unban of nodes
539  - fixed a race condition that could lead to monitoring being permanently disabled,
540    which would lead to long recovery times
541  - make deterministic IPs the default
542  - fixed a bug related to continuous recovery 
543  - added a debugging option --node-ip