66ca3301c9d979ea1a7f14bbaf7b31c12bea7260
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0.73
8 Release: 1
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 ## check for ccache
38 if ccache -h >/dev/null 2>&1 ; then
39         CC="ccache gcc"
40 else
41         CC="gcc"
42 fi
43
44 export CC
45
46 ## always run autogen.sh
47 ./autogen.sh
48
49 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
50         --prefix=%{_prefix} \
51         --sysconfdir=%{_sysconfdir} \
52         --mandir=%{_mandir} \
53         --localstatedir="/var"
54
55 make docdir=%{_docdir} showflags
56 make docdir=%{_docdir}
57
58 %install
59 # Clean up in case there is trash left from a previous build
60 rm -rf $RPM_BUILD_ROOT
61
62 # Create the target build directory hierarchy
63 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
64 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
65
66 make DESTDIR=$RPM_BUILD_ROOT docdir=%{_docdir} install
67
68 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
69 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
70
71 # Remove "*.old" files
72 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
79
80 %preun
81 if [ $1 = 0 ] ; then
82     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
83 fi
84 exit 0
85
86 %postun
87 if [ "$1" -ge "1" ]; then
88         %{initdir}/ctdb restart >/dev/null 2>&1 || true
89 fi      
90
91
92 #######################################################################
93 ## Files section                                                     ##
94 #######################################################################
95
96 %files
97 %defattr(-,root,root)
98
99 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
100 %config(noreplace) %{_sysconfdir}/ctdb/functions
101 %attr(755,root,root) %{initdir}/ctdb
102
103 %{_docdir}/ctdb/README.eventscripts
104 %{_docdir}/ctdb/recovery-process.txt
105 %{_sysconfdir}/ctdb/events.d/00.ctdb
106 %{_sysconfdir}/ctdb/events.d/10.interface
107 %{_sysconfdir}/ctdb/events.d/20.multipathd
108 %{_sysconfdir}/ctdb/events.d/40.vsftpd
109 %{_sysconfdir}/ctdb/events.d/41.httpd
110 %{_sysconfdir}/ctdb/events.d/50.samba
111 %{_sysconfdir}/ctdb/events.d/60.nfs
112 %{_sysconfdir}/ctdb/events.d/61.nfstickle
113 %{_sysconfdir}/ctdb/events.d/70.iscsi
114 %{_sysconfdir}/ctdb/events.d/90.ipmux
115 %{_sysconfdir}/ctdb/events.d/91.lvs
116 %{_sysconfdir}/ctdb/events.d/99.routing
117 %{_sysconfdir}/ctdb/statd-callout
118 %{_sbindir}/ctdbd
119 %{_bindir}/ctdb
120 %{_bindir}/smnotify
121 %{_bindir}/ctdb_ipmux
122 %{_bindir}/ctdb_diagnostics
123 %{_bindir}/onnode
124 %{_mandir}/man1/ctdb.1.gz
125 %{_mandir}/man1/ctdbd.1.gz
126 %{_mandir}/man1/onnode.1.gz
127 %{_includedir}/ctdb.h
128 %{_includedir}/ctdb_private.h
129
130 %changelog
131 * Wed Mar 4 2009 : Version 1.0.73
132  - Add possibility to disable the check of shares for NFS and Samba
133  - From Sumit Bose, fix dependencies so make -j works
134 * Wed Feb 18 2009 : Version 1.0.72
135  - Updates to test scripts by martin s
136  - Adding a COPYING file
137  - Use netstat to check for services and ports and fallback to netcat
138    only if netstat is unavailable.
139 * Mon Feb 2 2009 : Version 1.0.71
140  - Additional ipv6 fixes from Michael Adams
141 * Fri Jan 16 2009 : Version 1.0.70
142  - IPv6 support is completed. this is backward compatible with ipv4-only
143    systems. To use IPv6 with samba and ctdb you need current GIT of samba 3.3
144    or michael adams samba-ctdeb branch.
145  - Many enhancements to the build system and scripts to make it more SUSE
146    friendly by Michael Adams.
147  - Change of how the naming of the package is structured. We are now
148    using "1.0.70" as a release and "-1" as the revision instead of as
149    previously using "1.0" as release and ".70" as the revision.
150    By Michael Adams.
151 * Thu Dec 18 2008 : Version 1.0.69
152  - Various fixes to scripts by M Adam
153  - Dont call ctdb_fatal() when the transport is down during shutdown
154 * Fri Dec 12 2008 : Version 1.0.68
155  - Fixes for monitoring of interfaces status from Michael Adam.
156  - Use -q instead of >/dev/null for grep to enhance readability of the
157    scripts from Michael Adam.
158  - Update to the "ctdb recover" command. This command now block until the
159    has completed. This makes it much easier to use in scripts and avoids
160    the common workaround :
161       ctdb recover
162       ... loop while waiting for recovery completes ...
163       continue ...
164  - Add a CTDB_TIMEOUT variable. If set, this variable provides an automatic
165    timeout for "ctdb <command>", similar to using -T <timeout>
166  - Set a unique errorcode for "ctdb <command>" when it terminates due to a 
167    timeout so that scripts can distinguish between a hung command and what was
168    just a failure.
169  - Update "ctdb ban/unban" so that if the cluster is in recovery these commands
170    blocks and waits until after recovery is complete before the perform the
171    ban/unban operation. This is necessary since the recovery process can cause
172    nodes to become automatically unbanned.
173  - Update "ctdb ban/unban" to block until the recovery that will follow shortly
174    after this command has completed.
175    This makes it much easier to use in scripts and avoids the common
176    workaround :
177       ctdb ban/unban
178       ... loop while waiting for recovery completes ...
179       continue ...
180  - Bugfix for the new flags handling in 1.0.67. Abort and restart monitoring
181    if we failed to get proper nodemaps from a remote node instead of
182    dereferencing a null pointer.
183  - If ctdbd was explicitely started with the '--socket' argument, make
184    ctdbd automatically set CTDB_SOCKET to the specified argument.
185    This ensures that eventscripts spawned by the ctdb daemon will default to
186    using the same socket and talk to the correct daemon.
187    This primarily affects running multiple daemons on the same host and where 
188    you want each instance of ctdb daemons have their eventscripts talk to the
189    "correct" daemon.
190  - Update "ctdb ping" to return an error code if the ping fail so that it
191    can be used in scripts.
192  - Update to how to synchronize management of node flags across the cluster.
193 * Thu Dec 3 2008 : Version 1.0.67
194  - Add a document describing the recovery process.
195  - Fix a bug in "ctdb setdebug" where it would refuse to set a negative
196    debug level.
197  - Print the list of literals for debug names if an invalid one was given
198    to "ctdb setdebug"
199  - Redesign how "ctdb reloadnodes" works and reduce the amont of tcp teardowns
200    used during this event.
201  - Make it possible to delete a public ip from all nodes at once using
202    "ctdb delip -n all"
203 * Mon Nov 24 2008 : Version 1.0.66
204  - Allow to change the recmaster even when we are not frozen.
205  - Remove two redundant SAMBA_CHECK variables from the sysconf example
206  - After a node failure it can take very long before some lock operations
207    ctdb needs to perform are allowed/works with gpfs again. Workaround this
208    by treating a hang/timeout as success.
209  - Dont override CTDB_BASE is fet in the shell already
210  - Always send keepalive packets regardless of whether the link is idle or not.
211  - Rewrite the disable/enable flag update logic to prevent a race between 
212    "ctdb disable/enable" and the recovery daemon when updating the flags to 
213    all nodes.
214 * Thu Nov 13 2008 : Version 1.0.65
215  - Update the sysconfig example: The default debug level is 2 (NOTICE) and not
216    0 (ERROR)
217  - Add support for a CTDB_SOCKET environment variable for the ctdb command
218    line tool. If set, this overrides the default socket the ctdb tool will
219    use.
220  - Add logging of high latency operations.
221 * Mon Oct 22 2008 : Version 1.0.64
222  - Add a context and a timed event so that once we have been in recovery for
223    too long we drop all public addresses.
224 * Mon Oct 20 2008 : Version 1.0.63
225  - Remove logging of "periodic cleanup ..." in 50.samba
226  - When we reload a nodes file, we must detect this and reload the file also
227    in the recovery daemon before we try to dereference somethoung beyond the end
228    of the nodes array.
229 * Thu Oct 16 2008 : Version 1.0.62
230  - Allow multiple eventscritps using the same prefix number.
231    It is undefined which order scripts with the same prefix will execute in.
232 * Wed Oct 15 2008 : Version 1.0.61
233  - Use "route add -net" instead of "ip route add" when adding routes in 99.routing
234  - lower the loglevel os several debug statements
235  - check the status returned from ctdb_ctrl_get_tickles() before we try to print them out to the screen.
236  - install a new eventscript 20.multipathd whoich can be used to monitor that multipath devices are healthy
237 * Wed Oct 15 2008 : Version 1.0.60
238  - Verify that nodes we try to ban/unban are reachable and print an error othervise.
239  - Update the client and server sides of TAKEIP/RELEASEIP/GETPUBLICIPS and GETNODEMAP to fall back to the old style ipv4-only controls if the new ipv4/ipv6 controls fail. This allows an ipv4/v6 enabled ctdb daemon to interoperate with earlier ipv4-only versions of the daemons.
240  - From Mathieu Parent : log debian systems log the package versions in ctdb diagnostics
241  - From Mathieu Parent : specify logdir location for debian (this patch was later reversed)
242  - From Michael Adams : allow # comments in nodes/public_addresses files
243 * Tue Oct 7 2008 : Version 1.0.59
244  - Updated "reloadnodes" logic. Instead of bouncing the entire tcp layer it is sufficient to just close and reopen all outgoing tcp connections.
245  - New eventscript 99.routing which can be used to re-attach routes to public interfaces after a takeip event. (routes may be deleted by the kernel when we release an ip)
246  - IDR tree fix from Jim Houston
247  - Better handling of critical events if the local clock is suddenly changed forward by a lot.
248  - Fix three slow memory leaks in the recovery daemon
249  - New ctdb command : ctdb recmaster   which prints the pnn of the recmaster
250  - Onnode enhancements from Martin S : "healthy" and "connected" are now possible nodespecifiers
251  - From Martin S : doc fixes
252  - lowering some debug levels for some nonvital informational messages
253  - Make the daemon daemon monitoring stronger and allow ctdbd to detect a hung
254    recovery daemon.
255  - From C Cowan : patches to compile ipv6 under AIX
256  - zero out some structs to keep valgrind happy
257 * Wed Aug 27 2008 : Version 1.0.58
258  - revert the name change tcp_tcp_client back to tcp_control_tcp so
259    samba can build.
260  - Updates to the init script from Abhijith Das <adas@redhat.com>
261 * Mon Aug 25 2008 : Version 1.0.57
262  - initial support for IPv6
263 * Mon Aug 11 2008 : Version 1.0.56
264  - fix a memory leak in the recovery daemon.
265 * Mon Aug 11 2008 : Version 1.0.55
266  - Fix the releaseip message we seond to samba.
267 * Fri Aug 8 2008 : Version 1.0.54
268  - fix a looping error in the transaction code
269  - provide a more detailed error code for persistent store errors
270    so clients can make more intelligent choices on how to try to recover
271 * Thu Aug 7 2008 : Version 1.0.53
272  - Remove the reclock.pnn file   it can cause gpfs to fail to umount
273  - New transaction code
274 * Mon Aug 4 2008 : Version 1.0.52
275  - Send an explicit gratious arp when starting sending the tcp tickles.
276  - When doing failover, issue a killtcp to non-NFS/non-CIFS clients
277    so that they fail quickly. NFS and CIFS already fail and recover 
278    quickly.
279  - Update the test scripts to handle CTRL-C to kill off the test.
280 * Mon Jul 28 2008 : Version 1.0.51
281  - Strip off the vlan tag from bond devices before we check in /proc
282    if the interface is up or not.
283  - Use testparm in the background in the scripts to allow probing
284    that the shares do exist.
285  - Fix a bug in the logging code to handle multiline entries better
286  - Rename private elements from private to private_data
287 * Fri Jul 18 2008 : Version 1.0.50
288  - Dont assume that just because we can establish a TCP connection
289    that we are actually talking to a functioning ctdb daemon.
290    So dont mark the node as CONNECTED just because the tcp handshake
291    was successful.
292  - Dont try to set the recmaster to ourself during elections for those
293    cases we know this will fail. To remove some annoying benign but scary
294    looking entries from the log.
295  - Bugfix for eventsystem for signal handling that could cause a node to
296    hang.
297 * Thu Jul 17 2008 : Version 1.0.49
298  - Update the safe persistent update fix to work with unpatched samba
299    servers.
300 * Thu Jul 17 2008 : Version 1.0.48
301  - Update the spec file.
302  - Do not start new user-triggered eventscripts if we are already
303    inside recovery mode.
304  - Add two new controls to start/cancel a persistent update.
305    A client such as samba can use these to tell ctdbd that it will soon
306    be writing directly to the persistent database tdb file. So if
307    samba is -9ed before it has eitehr done the persistent_store or
308    canceled the operation, ctdb knows that the persistent databases
309    'may' be out of sync and therefore a full blown recovery is called for.
310  - Add two new options :
311    CTDB_SAMBA_SKIP_CONF_CHECK and CTDB_SAMBA_CHECK_PORTS that can be used
312    to override what checks to do when monitoring samba health.
313    We can no longer use the smbstatus, net or testparm commands to check
314    if samba or its config is healthy since these commands may block
315    indefinitely and thus can not be used in scripts.
316 * Fri Jul 11 2008 : Version 1.0.47
317  - Fix a double free bug where if a user striggered (ctdb eventscript)
318    hung and while the timeout handler was being processed a new user
319    triggered eventscript was started we would free state twice.
320  - Rewrite of onnode and associated documentation.
321 * Thu Jul 10 2008 : Version 1.0.46
322  - Document both the LVS:cingle-ip-address and the REMOTE-NODE:wan-accelerator
323    capabilities.
324  - Add commands "ctdb pnn", "ctdb lvs", "ctdb lvsmaster".
325  - LVS improvements. LVS is the single-ip-address mode for a ctdb cluster.
326  - Fixes to supress rpmlint warnings
327  - AXI compile fixes.
328  - Change \s to [[:space:]] in some scripts. Not all RHEL5 packages come
329    with a egrep that handles \s   even same version but different arch.
330  - Revert the change to NFS restart. CTDB should NOT attempt to restart
331    failed services.
332  - Rewrite of the waitpid() patch to use the eventsystem for handling
333    signals.
334 * Tue Jul 8 2008 : Version 1.0.45
335  - Try to restart the nfs service if it has failed to respond 3 times in a row.
336  - waitpid() can block if the child does not respond promptly to SIGTERM.
337    ignore all SIGCHILD signals by setting SIGCHLD to SIG_DEF.
338    get rid of all calls to waitpid().
339  - make handling of eventscripts hanging more liberal.
340    only consider the script to have failed and making the node unhealthy
341    IF the eventscript terminated wiht an error
342    OR the eventscript hung 5 or more times in a row
343 * Mon Jul 7 2008 : Version 1.0.44
344  - Add a CTDB_VALGRIND option to /etc/sysconfig/ctdb to make it start
345    ctdb under valgrind. Logs go to /var/log/ctdb_valgrind.PID
346  - Add a hack to show the control opcode that caused uninitialized data
347    in the valgrind output by encoding the opcode as the line number.
348  - Initialize structures and allocated memory in various places in
349    ctdb to make it valgrind-clean and remove all valgrind errors/warnings.
350  - If/when we destroy a lockwait child, also make sure we cancel any pending transactions
351  - If a transaction_commit fails, delete/cancel any pending transactions and
352    return an error instead of calling ctdb_fatal()
353  - When running ctdb under valgrind, make sure we run it with --nosetsched and also
354    ensure that we do not use mem-mapped i/o when accessing the tdb's.
355  - zero out ctdb->freeze_handle when we free/destroy a freeze-child.
356    This prevent a heap corruption/ctdb crash bug that could trigger
357    if the freeze child times out.
358  - we dont need to explicitely thaw the databases from the recovery daemon
359    since this is done implicitely when we restore the recovery mode back to normal.
360  - track when we start and stop a recovery. Add the 'time it took to complete the
361    recovery' to the 'ctdb uptime' output.
362    Ensure by tracking the start/stop recovery timestamps that we do not
363    check that the ip allocation is consistend from inside the recovery daemon
364    while a different node (recovery master) is performing a recovery.
365    This prevent a race that could cause a full recovery to trigger if the
366    'ctdb disable/enable' commands took very long.
367  - The freeze child indicates to the master daemon that all databases are locked
368    by writing data to the pipe shared with the master daemon.
369    This write sometimes fail and thus the master daemon never notices that the databases
370    are locked cvausing long timeouts and extra recoveries.
371    Check that the write is successful and try the write again if it failed.
372  - In each node, verify that the recmaster have the right node flags for us
373    and force a push of our flags to the recmaster if wrong.
374 * Tue Jul 1 2008 : Version 1.0.43
375  - Updates and bugfixes to the specfile to keep rpmlint happy
376  - Force a global flags update after each recovery event.
377  - Verify that the recmaster agrees with our node flags and update the
378    recmaster othervise.
379  - When writing back to the parent from a freeze-child across the pipe,
380    loop over the write in case the write failed with an error  othervise
381    the parent will never be notified tha the child has completed the operation.
382  - Automatically thaw all databases when recmaster marks us as being in normal
383    mode instead of recovery mode.
384 * Fri Jun 13 2008 : Version 1.0.42
385  - When event scripts have hung/timedout more than EventScriptBanCount times
386    in a row the node will ban itself.
387  - Many updates to persistent write tests and the test scripts.
388 * Wed May 28 2008 : Version 1.0.41
389  - Reactivate the safe writes to persistent databases and solve the
390    locking issues. Locking issues are solved the only possible way,
391    by using a child process to do the writes.  Expensive and slow but... . 
392 * Tue May 27 2008 : Version 1.0.40
393  - Read the samba sysconfig file from the 50.samba eventscript
394  - Fix some emmory hierarchical bugs in the persistent write handling
395 * Thu May 22 2008 : Version 1.0.39
396  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
397    into /etc/sysconfig/ctdb
398  - Lowered some debug messages to not fill the logfile with entries
399    that normally occur in the default configuration.
400 * Fri May 16 2008 : Version 1.0.38
401  - Add machine readable output support to "ctdb getmonmode"
402  - Lots of tweaks and enhancements if the event scripts are "slow"
403  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
404    net conf introduces if used from an eventscript.
405  - Enhance tickles so we can tickle an ipv6 connection.
406  - Start adding ipv6 support : create a new container to replace sockaddr_in.
407  - Add a checksum routine for ipv6/tcp
408  - When starting up ctdb, let the init script do a tdbdump on all
409    persistent databases and verify that they are good (i.e. not corrupted).
410  - Try to use "safe transactions" when writing to a persistent database
411    that was opened with the TDB_NOSYNC flag. If we can get the transaction
412    thats great, if we cant  we have to write anyway since we cant block here.
413 * Mon May 12 2008 : Version 1.0.37
414  - When we shutdown ctdb we close the transport down before we run the 
415    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
416    after we have shutdown the transport but before we have shutdown ctdbd
417    itself this could lead to a SEGV instead of a clean shutdown. Fix.
418  - When using the "exportfs" command to extract which NFS export directories
419    to monitor,  exportfs violates the "principle of least surprise" and
420    sometimes report a single export line as two lines of text output
421    causing the monitoring to fail.
422 * Fri May 9 2008 : Version 1.0.36
423  - fix a memory corruption bug that could cause the recovery daemon to crash.
424  - fix a bug with distributing public ip addresses during recovery.
425    If the node that is the recovery master did NOT use public addresses,
426    then it assumed that no other node in the cluster used them either and
427    thus skipped the entire step of reallocating public addresses.
428 * Wed May 7 2008 : Version 1.0.35
429  - During recovery, when we define the new set of lmasters (vnnmap)
430    only consider those nodes that have the can-be-lmaster capability
431    when we create the vnnmap. unless there are no nodes available which
432    supports this capability in which case we allow the recmaster to
433    become lmaster capable (temporarily).
434  - Extend the async framework so that we can use paralell async calls
435    to controls that return data.
436  - If we do not have the "can be recmaster" capability, make sure we will
437    lose any recmaster elections, unless there are no nodes available that
438    have the capability, in which case we "take/win" the election anyway.
439  - Close and reopen the reclock pnn file at regular intervals.
440    Make it a non-fatal event if we occasionally fail to open/read/write
441    to this file.
442  - Monitor that the recovery daemon is still running from the main ctdb
443    daemon and shutdown the main daemon when recovery daemon has terminated.
444  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
445  - Define two new capabilities : can be recmaster and can be lmaster
446    and default both capabilities to YES.
447  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
448 * Thu Apr 24 2008 : Version 1.0.34
449  - When deleting a public ip from a node, try to migrate the ip to a different
450    node first.
451  - Change catdb to produce output similar to tdbdump
452  - When adding a new public ip address, if this ip does not exist yet in
453    the cluster, then grab the ip on the local node and activate it.
454  - When a node disagrees with the recmaster on WHO is the recmaster, then
455    mark that node as a recovery culprit so it will eventually become
456    banned.
457  - Make ctdb eventscript support the -n all argument.
458 * Thu Apr 10 2008 : Version 1.0.33
459  - Add facilities to include site local adaptations to the eventscript
460    by /etc/ctdb/rc.local which will be read by all eventscripts.
461  - Add a "ctdb version" command.
462  - Secure the domain socket with proper permissions from Chris Cowan
463  - Bugfixes for AIX from Chris Cowan
464 * Wed Apr 02 2008 : Version 1.0.32
465  - Add a control to have a node execute the eventscripts with arbitrary
466    command line arguments.
467  - Add a control "rddumpmemory" that will dump the talloc memory allocations
468    for the recovery daemon.
469  - Decorate the talloc memdump to produce better and easier memory leak
470    tracking. 
471  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
472    public address.
473  - Add two new controls "addip/delip" that can be used to add/remove public
474    addresses to a node at runtime. After using these controls a "ctdb recover"
475    ir required to make the changes take.
476  - Fix a couple of slow memory leaks.
477 * Tue Mar 25 2008 : Version 1.0.31
478  - Add back controls to disable/enable monitoring on a node.
479  - Fix a memory leak where we used to attach CALL data to the ctdb structure
480    when performing a local call. Memory which would be lost if the call was
481    aborted.
482  - Reduce the loglevel for the log output when someone connects to a non
483    public ip address for samba.
484  - Redo and optimize the vacuuming process to send only one control to each
485    other node containing all records to be vacuumed instead of one
486    control per node per record.
487 * Tue Mar 04 2008 : Version 1.0.30
488  - Update documentation cor new commands and tuneables
489  - Add machinereadable output to the ip,uptime and getdebug commands
490  - Add a moveip command to manually failover/failback public ips
491  - Add NoIPFallback tuneable that prevents ip address failback
492  - Use file locking inside the CFS as alternative to verify when other nodes
493    Are connected/disconnected to be able to recover from split network
494  - Add DisableWhenUnhealthy tunable
495  - Add CTDB_START_AS_DISABLED sysconfig param
496  - Add --start-as-disabled flag to ctdb
497  - Add ability to monitor for OOM condition
498 * Thu Feb 21 2008 : Version 1.0.29
499  - Add a new command to make expansion of an existing cluster easier
500  - Fix bug with references to freed objects in the ctdb structure
501  - Propagate debuglevel changes to the recovery daemon
502  - Merge patches to event scripts from Mathieu Parent :
503  - MP: Simulate "service" on systems which do not provide this tool
504  - MP: Set correct permissions for events.d/README
505  - Add nice helper functions to start/stop nfs from the event scripts
506 * Fri Feb 08 2008 : Version 1.0.28
507  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
508  - Warn if the ipvsadm packege is missing when LVS is used
509  - Dont use absolute pathnames in some of the event scripts
510  - Fix for persistent tdbs growing inifinitely.
511 * Wed Feb 06 2008 : Version 1.0.27
512  - Add eventscript for iscsi
513 * Thu Jan 31 2008 : Version 1.0.26
514  - Fix crashbug in tdb transaction code
515 * Tue Jan 29 2008 : Version 1.0.25
516  - added async recovery code
517  - make event scripts more portable
518  - fixed ctdb dumpmemory
519  - more efficient tdb allocation code
520  - improved machine readable ctdb status output
521  - added ctdb uptime
522 * Wed Jan 16 2008 : Version 1.0.24
523  - added syslog support
524  - documentation updates
525 * Wed Jan 16 2008 : Version 1.0.23
526  - fixed a memory leak in the recoveryd
527  - fixed a corruption bug in the new transaction code
528  - fixed a case where an packet for a disconnected client could be processed
529  - added http event script
530  - updated documentation
531 * Thu Jan 10 2008 : Version 1.0.22
532  - auto-run vacuum and repack ops
533 * Wed Jan 09 2008 : Version 1.0.21
534  - added ctdb vacuum and ctdb repack code
535 * Sun Jan 06 2008 : Version 1.0.20
536  - new transaction based recovery code
537 * Sat Jan 05 2008 : Version 1.0.19
538  - fixed non-master bug
539  - big speedup in recovery for large databases
540  - lots of changes to improve tdb and ctdb for high churn databases
541 * Thu Dec 27 2007 : Version 1.0.18
542  - fixed crash bug in monitor_handler
543 * Tue Dec 04 2007 : Version 1.0.17
544  - fixed bugs related to ban/unban of nodes
545  - fixed a race condition that could lead to monitoring being permanently disabled,
546    which would lead to long recovery times
547  - make deterministic IPs the default
548  - fixed a bug related to continuous recovery 
549  - added a debugging option --node-ip