cb5cd6a095301759bc04c6536f82a4bb9b4cbddf
[metze/ctdb/wip.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0
8 Release: 55
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 CC="gcc"
38
39 ## always run autogen.sh
40 ./autogen.sh
41
42 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
43         --prefix=%{_prefix} \
44         --sysconfdir=%{_sysconfdir} \
45         --mandir=%{_mandir} \
46         --localstatedir="/var"
47
48 make showflags
49 make   
50
51 %install
52 # Clean up in case there is trash left from a previous build
53 rm -rf $RPM_BUILD_ROOT
54
55 # Create the target build directory hierarchy
56 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
57 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
58
59 make DESTDIR=$RPM_BUILD_ROOT install
60
61 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
62 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
63
64 # Remove "*.old" files
65 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
72
73 %preun
74 if [ $1 = 0 ] ; then
75     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
76 fi
77 exit 0
78
79 %postun
80 if [ "$1" -ge "1" ]; then
81         %{initdir}/ctdb restart >/dev/null 2>&1 || true
82 fi      
83
84
85 #######################################################################
86 ## Files section                                                     ##
87 #######################################################################
88
89 %files
90 %defattr(-,root,root)
91
92 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
93 %config(noreplace) %{_sysconfdir}/ctdb/functions
94 %attr(755,root,root) %{initdir}/ctdb
95
96 %{_docdir}/ctdb/README.eventscripts
97 %{_sysconfdir}/ctdb/events.d/00.ctdb
98 %{_sysconfdir}/ctdb/events.d/10.interface
99 %{_sysconfdir}/ctdb/events.d/40.vsftpd
100 %{_sysconfdir}/ctdb/events.d/41.httpd
101 %{_sysconfdir}/ctdb/events.d/50.samba
102 %{_sysconfdir}/ctdb/events.d/60.nfs
103 %{_sysconfdir}/ctdb/events.d/61.nfstickle
104 %{_sysconfdir}/ctdb/events.d/70.iscsi
105 %{_sysconfdir}/ctdb/events.d/90.ipmux
106 %{_sysconfdir}/ctdb/events.d/91.lvs
107 %{_sysconfdir}/ctdb/statd-callout
108 %{_sbindir}/ctdbd
109 %{_bindir}/ctdb
110 %{_bindir}/smnotify
111 %{_bindir}/ctdb_ipmux
112 %{_bindir}/ctdb_diagnostics
113 %{_bindir}/onnode
114 %{_mandir}/man1/ctdb.1.gz
115 %{_mandir}/man1/ctdbd.1.gz
116 %{_mandir}/man1/onnode.1.gz
117 %{_includedir}/ctdb.h
118 %{_includedir}/ctdb_private.h
119
120 %changelog
121 * Mon Aug 11 2008 : Version 1.0.55
122  - Fix the releaseip message we seond to samba.
123 * Fri Aug 8 2008 : Version 1.0.54
124  - fix a looping error in the transaction code
125  - provide a more detailed error code for persistent store errors
126    so clients can make more intelligent choices on how to try to recover
127 * Thu Aug 7 2008 : Version 1.0.53
128  - Remove the reclock.pnn file   it can cause gpfs to fail to umount
129  - New transaction code
130 * Mon Aug 4 2008 : Version 1.0.52
131  - Send an explicit gratious arp when starting sending the tcp tickles.
132  - When doing failover, issue a killtcp to non-NFS/non-CIFS clients
133    so that they fail quickly. NFS and CIFS already fail and recover 
134    quickly.
135  - Update the test scripts to handle CTRL-C to kill off the test.
136 * Mon Jul 28 2008 : Version 1.0.51
137  - Strip off the vlan tag from bond devices before we check in /proc
138    if the interface is up or not.
139  - Use testparm in the background in the scripts to allow probing
140    that the shares do exist.
141  - Fix a bug in the logging code to handle multiline entries better
142  - Rename private elements from private to private_data
143 * Fri Jul 18 2008 : Version 1.0.50
144  - Dont assume that just because we can establish a TCP connection
145    that we are actually talking to a functioning ctdb daemon.
146    So dont mark the node as CONNECTED just because the tcp handshake
147    was successful.
148  - Dont try to set the recmaster to ourself during elections for those
149    cases we know this will fail. To remove some annoying benign but scary
150    looking entries from the log.
151  - Bugfix for eventsystem for signal handling that could cause a node to
152    hang.
153 * Thu Jul 17 2008 : Version 1.0.49
154  - Update the safe persistent update fix to work with unpatched samba
155    servers.
156 * Thu Jul 17 2008 : Version 1.0.48
157  - Update the spec file.
158  - Do not start new user-triggered eventscripts if we are already
159    inside recovery mode.
160  - Add two new controls to start/cancel a persistent update.
161    A client such as samba can use these to tell ctdbd that it will soon
162    be writing directly to the persistent database tdb file. So if
163    samba is -9ed before it has eitehr done the persistent_store or
164    canceled the operation, ctdb knows that the persistent databases
165    'may' be out of sync and therefore a full blown recovery is called for.
166  - Add two new options :
167    CTDB_SAMBA_SKIP_CONF_CHECK and CTDB_SAMBA_CHECK_PORTS that can be used
168    to override what checks to do when monitoring samba health.
169    We can no longer use the smbstatus, net or testparm commands to check
170    if samba or its config is healthy since these commands may block
171    indefinitely and thus can not be used in scripts.
172 * Fri Jul 11 2008 : Version 1.0.47
173  - Fix a double free bug where if a user striggered (ctdb eventscript)
174    hung and while the timeout handler was being processed a new user
175    triggered eventscript was started we would free state twice.
176  - Rewrite of onnode and associated documentation.
177 * Thu Jul 10 2008 : Version 1.0.46
178  - Document both the LVS:cingle-ip-address and the REMOTE-NODE:wan-accelerator
179    capabilities.
180  - Add commands "ctdb pnn", "ctdb lvs", "ctdb lvsmaster".
181  - LVS improvements. LVS is the single-ip-address mode for a ctdb cluster.
182  - Fixes to supress rpmlint warnings
183  - AXI compile fixes.
184  - Change \s to [[:space:]] in some scripts. Not all RHEL5 packages come
185    with a egrep that handles \s   even same version but different arch.
186  - Revert the change to NFS restart. CTDB should NOT attempt to restart
187    failed services.
188  - Rewrite of the waitpid() patch to use the eventsystem for handling
189    signals.
190 * Tue Jul 8 2008 : Version 1.0.45
191  - Try to restart the nfs service if it has failed to respond 3 times in a row.
192  - waitpid() can block if the child does not respond promptly to SIGTERM.
193    ignore all SIGCHILD signals by setting SIGCHLD to SIG_DEF.
194    get rid of all calls to waitpid().
195  - make handling of eventscripts hanging more liberal.
196    only consider the script to have failed and making the node unhealthy
197    IF the eventscript terminated wiht an error
198    OR the eventscript hung 5 or more times in a row
199 * Mon Jul 7 2008 : Version 1.0.44
200  - Add a CTDB_VALGRIND option to /etc/sysconfig/ctdb to make it start
201    ctdb under valgrind. Logs go to /var/log/ctdb_valgrind.PID
202  - Add a hack to show the control opcode that caused uninitialized data
203    in the valgrind output by encoding the opcode as the line number.
204  - Initialize structures and allocated memory in various places in
205    ctdb to make it valgrind-clean and remove all valgrind errors/warnings.
206  - If/when we destroy a lockwait child, also make sure we cancel any pending transactions
207  - If a transaction_commit fails, delete/cancel any pending transactions and
208    return an error instead of calling ctdb_fatal()
209  - When running ctdb under valgrind, make sure we run it with --nosetsched and also
210    ensure that we do not use mem-mapped i/o when accessing the tdb's.
211  - zero out ctdb->freeze_handle when we free/destroy a freeze-child.
212    This prevent a heap corruption/ctdb crash bug that could trigger
213    if the freeze child times out.
214  - we dont need to explicitely thaw the databases from the recovery daemon
215    since this is done implicitely when we restore the recovery mode back to normal.
216  - track when we start and stop a recovery. Add the 'time it took to complete the
217    recovery' to the 'ctdb uptime' output.
218    Ensure by tracking the start/stop recovery timestamps that we do not
219    check that the ip allocation is consistend from inside the recovery daemon
220    while a different node (recovery master) is performing a recovery.
221    This prevent a race that could cause a full recovery to trigger if the
222    'ctdb disable/enable' commands took very long.
223  - The freeze child indicates to the master daemon that all databases are locked
224    by writing data to the pipe shared with the master daemon.
225    This write sometimes fail and thus the master daemon never notices that the databases
226    are locked cvausing long timeouts and extra recoveries.
227    Check that the write is successful and try the write again if it failed.
228  - In each node, verify that the recmaster have the right node flags for us
229    and force a push of our flags to the recmaster if wrong.
230 * Tue Jul 1 2008 : Version 1.0.43
231  - Updates and bugfixes to the specfile to keep rpmlint happy
232  - Force a global flags update after each recovery event.
233  - Verify that the recmaster agrees with our node flags and update the
234    recmaster othervise.
235  - When writing back to the parent from a freeze-child across the pipe,
236    loop over the write in case the write failed with an error  othervise
237    the parent will never be notified tha the child has completed the operation.
238  - Automatically thaw all databases when recmaster marks us as being in normal
239    mode instead of recovery mode.
240 * Fri Jun 13 2008 : Version 1.0.42
241  - When event scripts have hung/timedout more than EventScriptBanCount times
242    in a row the node will ban itself.
243  - Many updates to persistent write tests and the test scripts.
244 * Wed May 28 2008 : Version 1.0.41
245  - Reactivate the safe writes to persistent databases and solve the
246    locking issues. Locking issues are solved the only possible way,
247    by using a child process to do the writes.  Expensive and slow but... . 
248 * Tue May 27 2008 : Version 1.0.40
249  - Read the samba sysconfig file from the 50.samba eventscript
250  - Fix some emmory hierarchical bugs in the persistent write handling
251 * Thu May 22 2008 : Version 1.0.39
252  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
253    into /etc/sysconfig/ctdb
254  - Lowered some debug messages to not fill the logfile with entries
255    that normally occur in the default configuration.
256 * Fri May 16 2008 : Version 1.0.38
257  - Add machine readable output support to "ctdb getmonmode"
258  - Lots of tweaks and enhancements if the event scripts are "slow"
259  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
260    net conf introduces if used from an eventscript.
261  - Enhance tickles so we can tickle an ipv6 connection.
262  - Start adding ipv6 support : create a new container to replace sockaddr_in.
263  - Add a checksum routine for ipv6/tcp
264  - When starting up ctdb, let the init script do a tdbdump on all
265    persistent databases and verify that they are good (i.e. not corrupted).
266  - Try to use "safe transactions" when writing to a persistent database
267    that was opened with the TDB_NOSYNC flag. If we can get the transaction
268    thats great, if we cant  we have to write anyway since we cant block here.
269 * Mon May 12 2008 : Version 1.0.37
270  - When we shutdown ctdb we close the transport down before we run the 
271    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
272    after we have shutdown the transport but before we have shutdown ctdbd
273    itself this could lead to a SEGV instead of a clean shutdown. Fix.
274  - When using the "exportfs" command to extract which NFS export directories
275    to monitor,  exportfs violates the "principle of least surprise" and
276    sometimes report a single export line as two lines of text output
277    causing the monitoring to fail.
278 * Fri May 9 2008 : Version 1.0.36
279  - fix a memory corruption bug that could cause the recovery daemon to crash.
280  - fix a bug with distributing public ip addresses during recovery.
281    If the node that is the recovery master did NOT use public addresses,
282    then it assumed that no other node in the cluster used them either and
283    thus skipped the entire step of reallocating public addresses.
284 * Wed May 7 2008 : Version 1.0.35
285  - During recovery, when we define the new set of lmasters (vnnmap)
286    only consider those nodes that have the can-be-lmaster capability
287    when we create the vnnmap. unless there are no nodes available which
288    supports this capability in which case we allow the recmaster to
289    become lmaster capable (temporarily).
290  - Extend the async framework so that we can use paralell async calls
291    to controls that return data.
292  - If we do not have the "can be recmaster" capability, make sure we will
293    lose any recmaster elections, unless there are no nodes available that
294    have the capability, in which case we "take/win" the election anyway.
295  - Close and reopen the reclock pnn file at regular intervals.
296    Make it a non-fatal event if we occasionally fail to open/read/write
297    to this file.
298  - Monitor that the recovery daemon is still running from the main ctdb
299    daemon and shutdown the main daemon when recovery daemon has terminated.
300  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
301  - Define two new capabilities : can be recmaster and can be lmaster
302    and default both capabilities to YES.
303  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
304 * Thu Apr 24 2008 : Version 1.0.34
305  - When deleting a public ip from a node, try to migrate the ip to a different
306    node first.
307  - Change catdb to produce output similar to tdbdump
308  - When adding a new public ip address, if this ip does not exist yet in
309    the cluster, then grab the ip on the local node and activate it.
310  - When a node disagrees with the recmaster on WHO is the recmaster, then
311    mark that node as a recovery culprit so it will eventually become
312    banned.
313  - Make ctdb eventscript support the -n all argument.
314 * Thu Apr 10 2008 : Version 1.0.33
315  - Add facilities to include site local adaptations to the eventscript
316    by /etc/ctdb/rc.local which will be read by all eventscripts.
317  - Add a "ctdb version" command.
318  - Secure the domain socket with proper permissions from Chris Cowan
319  - Bugfixes for AIX from Chris Cowan
320 * Wed Apr 02 2008 : Version 1.0.32
321  - Add a control to have a node execute the eventscripts with arbitrary
322    command line arguments.
323  - Add a control "rddumpmemory" that will dump the talloc memory allocations
324    for the recovery daemon.
325  - Decorate the talloc memdump to produce better and easier memory leak
326    tracking. 
327  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
328    public address.
329  - Add two new controls "addip/delip" that can be used to add/remove public
330    addresses to a node at runtime. After using these controls a "ctdb recover"
331    ir required to make the changes take.
332  - Fix a couple of slow memory leaks.
333 * Tue Mar 25 2008 : Version 1.0.31
334  - Add back controls to disable/enable monitoring on a node.
335  - Fix a memory leak where we used to attach CALL data to the ctdb structure
336    when performing a local call. Memory which would be lost if the call was
337    aborted.
338  - Reduce the loglevel for the log output when someone connects to a non
339    public ip address for samba.
340  - Redo and optimize the vacuuming process to send only one control to each
341    other node containing all records to be vacuumed instead of one
342    control per node per record.
343 * Tue Mar 04 2008 : Version 1.0.30
344  - Update documentation cor new commands and tuneables
345  - Add machinereadable output to the ip,uptime and getdebug commands
346  - Add a moveip command to manually failover/failback public ips
347  - Add NoIPFallback tuneable that prevents ip address failback
348  - Use file locking inside the CFS as alternative to verify when other nodes
349    Are connected/disconnected to be able to recover from split network
350  - Add DisableWhenUnhealthy tunable
351  - Add CTDB_START_AS_DISABLED sysconfig param
352  - Add --start-as-disabled flag to ctdb
353  - Add ability to monitor for OOM condition
354 * Thu Feb 21 2008 : Version 1.0.29
355  - Add a new command to make expansion of an existing cluster easier
356  - Fix bug with references to freed objects in the ctdb structure
357  - Propagate debuglevel changes to the recovery daemon
358  - Merge patches to event scripts from Mathieu Parent :
359  - MP: Simulate "service" on systems which do not provide this tool
360  - MP: Set correct permissions for events.d/README
361  - Add nice helper functions to start/stop nfs from the event scripts
362 * Fri Feb 08 2008 : Version 1.0.28
363  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
364  - Warn if the ipvsadm packege is missing when LVS is used
365  - Dont use absolute pathnames in some of the event scripts
366  - Fix for persistent tdbs growing inifinitely.
367 * Wed Feb 06 2008 : Version 1.0.27
368  - Add eventscript for iscsi
369 * Thu Jan 31 2008 : Version 1.0.26
370  - Fix crashbug in tdb transaction code
371 * Tue Jan 29 2008 : Version 1.0.25
372  - added async recovery code
373  - make event scripts more portable
374  - fixed ctdb dumpmemory
375  - more efficient tdb allocation code
376  - improved machine readable ctdb status output
377  - added ctdb uptime
378 * Wed Jan 16 2008 : Version 1.0.24
379  - added syslog support
380  - documentation updates
381 * Wed Jan 16 2008 : Version 1.0.23
382  - fixed a memory leak in the recoveryd
383  - fixed a corruption bug in the new transaction code
384  - fixed a case where an packet for a disconnected client could be processed
385  - added http event script
386  - updated documentation
387 * Thu Jan 10 2008 : Version 1.0.22
388  - auto-run vacuum and repack ops
389 * Wed Jan 09 2008 : Version 1.0.21
390  - added ctdb vacuum and ctdb repack code
391 * Sun Jan 06 2008 : Version 1.0.20
392  - new transaction based recovery code
393 * Sat Jan 05 2008 : Version 1.0.19
394  - fixed non-master bug
395  - big speedup in recovery for large databases
396  - lots of changes to improve tdb and ctdb for high churn databases
397 * Thu Dec 27 2007 : Version 1.0.18
398  - fixed crash bug in monitor_handler
399 * Tue Dec 04 2007 : Version 1.0.17
400  - fixed bugs related to ban/unban of nodes
401  - fixed a race condition that could lead to monitoring being permanently disabled,
402    which would lead to long recovery times
403  - make deterministic IPs the default
404  - fixed a bug related to continuous recovery 
405  - added a debugging option --node-ip