r25598: Add missing become_root/unbecome_root around calls of add_aliases.
[samba.git] / source / python / setup.py
index ce417710b30c9308ebef969ef20adc9af5adb9e2..21717de659bbeec2c8287e05c92f726ae5ebad7a 100755 (executable)
@@ -8,7 +8,7 @@
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
+# the Free Software Foundation; either version 3 of the License, or
 # (at your option) any later version.
 #   
 # This program is distributed in the hope that it will be useful,
@@ -17,8 +17,7 @@
 # GNU General Public License for more details.
 #   
 # You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# along with this program; if not, see <http://www.gnu.org/licenses/>.
 #
 
 from distutils.core import setup
@@ -67,6 +66,8 @@ for lib in string.split(samba_libs):
         libraries.append(lib[2:])
     elif lib[0:8] == ("-pthread"):
         pass # Skip linker flags
+    elif lib[0:4] == ("-pie"):
+        pass # Skip linker flags
     elif lib[0:2] == "-L":
         library_dirs.append(lib[2:])
     elif lib[0:2] in ("-W","-s"):