Build .so for talloc.
authorctrlsoft-guest <ctrlsoft-guest>
Sun, 29 Apr 2007 21:22:09 +0000 (21:22 +0000)
committerctrlsoft-guest <ctrlsoft-guest>
Sun, 29 Apr 2007 21:22:09 +0000 (21:22 +0000)
debian/control
debian/libtalloc0.install [deleted file]
debian/libtalloc1.install [new file with mode: 0644]
debian/patches/series [new file with mode: 0644]
debian/patches/solib.patch [new file with mode: 0644]
debian/rules

index 50d0fe7fb5e32f0a5c34198efaf9ae9983dfe726..663ef0ab25f6e638b3b25df61c52127a24799234 100644 (file)
@@ -2,12 +2,11 @@ Source: talloc
 Section: devel
 Priority: optional
 Maintainer: Debian Samba Maintainers <samba-maint@alioth.debian.org>
-Build-Depends: debhelper (>= 5.0.37.2)
+Build-Depends: debhelper (>= 5.0.37.2), quilt (>= 0.40)
 Standards-Version: 3.7.2
-XS-Python-Version: >= 2.4
 XS-Vcs-Svn: svn://svn.debian.org/pkg-samba/trunk/talloc
 
-Package: libtalloc0
+Package: libtalloc1
 Architecture: any
 Depends: ${shlibs:Depends}
 Description: Hierarchical pool based memory allocator
diff --git a/debian/libtalloc0.install b/debian/libtalloc0.install
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/debian/libtalloc1.install b/debian/libtalloc1.install
new file mode 100644 (file)
index 0000000..3695c07
--- /dev/null
@@ -0,0 +1 @@
+usr/lib/libtalloc.so.1*
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644 (file)
index 0000000..dc39dc8
--- /dev/null
@@ -0,0 +1 @@
+solib.patch
diff --git a/debian/patches/solib.patch b/debian/patches/solib.patch
new file mode 100644 (file)
index 0000000..d64e886
--- /dev/null
@@ -0,0 +1,38 @@
+diff -ur talloc-1.0/Makefile.in talloc-1.0-debian/Makefile.in
+--- talloc-1.0/Makefile.in     2007-04-25 16:18:22.000000000 +0200
++++ talloc-1.0-debian/Makefile.in      2007-04-30 01:15:47.000000000 +0200
+@@ -19,7 +19,9 @@
+ LIBOBJ = @TALLOCOBJ@ @LIBREPLACEOBJ@
+-all: showflags libtalloc.a testsuite $(EXTRA_TARGETS)
++SOLIB = libtalloc.so.1.0.0
++
++all: showflags libtalloc.a $(SOLIB) testsuite $(EXTRA_TARGETS)
+ showflags:
+       @echo 'talloc will be compiled with flags:'
+@@ -33,10 +35,14 @@
+       ar -rv $@ $(LIBOBJ)
+       @-ranlib $@
++$(SOLIB): $(LIBOBJ)
++      $(CC) -Wl,-soname,$(SOLIB) -shared -o $@ $^
++
+ install: all 
+       ${INSTALLCMD} -d $(DESTDIR)${libdir}
+       ${INSTALLCMD} -d $(DESTDIR)${libdir}/pkgconfig
+       ${INSTALLCMD} -m 755 libtalloc.a $(DESTDIR)$(libdir)
++      ${INSTALLCMD} -m 755 $(SOLIB) $(DESTDIR)$(libdir)
+       ${INSTALLCMD} -d $(DESTDIR)${includedir}
+       ${INSTALLCMD} -m 644 $(srcdir)/talloc.h $(DESTDIR)$(includedir)
+       ${INSTALLCMD} -m 644 talloc.pc $(DESTDIR)$(libdir)/pkgconfig
+@@ -52,7 +58,7 @@
+       -test -z "$(XSLTPROC)" || $(XSLTPROC) --nonet -o $@ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $<
+ clean:
+-      rm -f *~ $(LIBOBJ) libtalloc.a testsuite testsuite.o *.gc?? talloc.3 talloc.3.html
++      rm -f *~ $(LIBOBJ) $(SOLIB) libtalloc.a testsuite testsuite.o *.gc?? talloc.3 talloc.3.html
+ test: testsuite
+       ./testsuite
index 5091d2ab232f6b7190af2e845dec42dcc5629e8d..eeecc200a3d160769aca5b7d467fc50b4f405edd 100755 (executable)
@@ -8,6 +8,8 @@ else
   CFLAGS += -O2
 endif
 
+include /usr/share/quilt/quilt.make
+
 DESTDIR=`pwd`/debian/tmp
 
 conf_args = --prefix=/usr