Use new upstream snapshot.
authorJelmer Vernooij <jelmer@samba.org>
Tue, 21 Dec 2010 16:02:20 +0000 (17:02 +0100)
committerJelmer Vernooij <jelmer@samba.org>
Tue, 21 Dec 2010 16:02:20 +0000 (17:02 +0100)
debian/build-orig.sh
debian/changelog
debian/libtevent0.symbols

index 766b7ecffa19d52591a312435782a1560a576f73..0674ac1151a4b4bf2ca7634970fc355dc03566b8 100755 (executable)
@@ -1,15 +1,14 @@
 #!/bin/bash -e
 
-if [ -z "$GIT_URL" ]; then
-       GIT_URL=git://git.samba.org/samba.git
+if [ -z "$SAMBA_GIT_URL" ]; then
+       SAMBA_GIT_URL=git://git.samba.org/samba.git
 fi
 
 TEVENTTMP=`mktemp -d`
-git clone --depth 1 $GIT_URL $TEVENTTMP
-if [ ! -z "$REFSPEC" ]; then
-       pushd $TEVENTTMP
-       git checkout $REFSPEC || exit 1
-       popd
+if [ -d $SAMBA_GIT_URL/.bzr ]; then
+       bzr co --lightweight $SAMBA_GIT_URL $TEVENTTMP
+else
+       git clone --depth 1 $SAMBA_GIT_URL $TEVENTTMP
 fi
 pushd $TEVENTTMP/lib/tevent
 ./configure
index 2dc754f6f88acec9454e42f240bcd7f4dec56364..bba3cd7b757306fd3f0f8311f71984d4ed0cdfb3 100644 (file)
@@ -1,4 +1,4 @@
-tevent (0.9.9~git20101215-1) unstable; urgency=low
+tevent (0.9.9~git20101221-1) unstable; urgency=low
 
   * New upstream snapshot.
   * Remove reference to deprecated BSD license file.
index d63a3fdd6b91c2876d88f54fd14de4ef92fcefbd..8c73655bca00f59a000c9f51b8028f4d5c70c941 100644 (file)
@@ -17,15 +17,6 @@ libtevent.so.0 #PACKAGE# #MINVER#
  _tevent_req_nomem@TEVENT_0.9.9 0.9.9~git20101215
  _tevent_req_notify_callback@TEVENT_0.9.9 0.9.9~git20101215
  _tevent_schedule_immediate@TEVENT_0.9.9 0.9.9~git20101215
- dummy_snprintf@TEVENT_0.9.9 0.9.9~git20101215
- ev_set_blocking@TEVENT_0.9.9 0.9.9~git20101215
- ev_str_list_add@TEVENT_0.9.9 0.9.9~git20101215
- ev_str_list_length@TEVENT_0.9.9 0.9.9~git20101215
- rep_getpass@TEVENT_0.9.9 0.9.9~git20101215
- rep_strerror_r@TEVENT_0.9.9 0.9.9~git20101215
- rep_strlcat@TEVENT_0.9.9 0.9.9~git20101215
- rep_strlcpy@TEVENT_0.9.9 0.9.9~git20101215
- replace_dummy@TEVENT_0.9.9 0.9.9~git20101215
  tevent_backend_list@TEVENT_0.9.9 0.9.9~git20101215
  tevent_cleanup_pending_signal_handlers@TEVENT_0.9.9 0.9.9~git20101215
  tevent_common_add_fd@TEVENT_0.9.9 0.9.9~git20101215