Support nocheck in DEB_BUILD_OPTIONS rather than notest (per policy
authorJelmer Vernooij <jelmer@debian.org>
Mon, 1 Nov 2010 18:21:38 +0000 (19:21 +0100)
committerJelmer Vernooij <jelmer@debian.org>
Mon, 1 Nov 2010 18:21:38 +0000 (19:21 +0100)
4.9.1).

1  2 
debian/build-orig.sh
debian/changelog
debian/control
debian/libpytalloc-util-dev.install
debian/rules

index a7968a2a064c0ec7b10399d77a57b73360691ce5,0000000000000000000000000000000000000000..f1a8afd72df60bb278907718403f272e4a6c1e86
mode 100755,000000..100755
--- /dev/null
@@@ -1,24 -1,0 +1,21 @@@
- GIT_URL=$1
- REFSPEC=$2
- shift 2
 +#!/bin/bash
 +
 +if [ -z "$GIT_URL" ]; then
 +      GIT_URL=git://git.samba.org/samba.git
 +fi
 +
 +TALLOCTMP=$TMPDIR/$RANDOM.talloc.git
 +git clone --depth 1 $GIT_URL $TALLOCTMP
 +if [ ! -z "$REFSPEC" ]; then
 +      pushd $TALLOCTMP
 +      git checkout $REFSPEC || exit 1
 +      popd
 +fi
 +pushd $TALLOCTMP/lib/talloc
 +./autogen-waf.sh
 +./configure
 +make dist
 +popd
 +version=$( dpkg-parsechangelog -l`dirname $0`/changelog | sed -n 's/^Version: \(.*:\|\)//p' | sed 's/-[0-9.]\+$//' )
 +mv $TALLOCTMP/lib/talloc/talloc-*.tar.gz talloc-$version.tar.gz
 +rm -rf $TALLOCTMP
index fc7ece61c582fc0a573eb1672855ecbeffed3f2a,0000000000000000000000000000000000000000..c05cfdfffd32a49932e3564cbafe6776fa7d6ab2
mode 100644,000000..100644
--- /dev/null
@@@ -1,137 -1,0 +1,139 @@@
- talloc (2.0.3~git20101030b-1) experimental; urgency=low
++talloc (2.0.3~git20101101-1) UNRELEASED; urgency=low
 +
 +  * New upstream snapshot.
 +   + Fixes example include line in manual page. Closes: #588393
 +   + Removes manual page mention of deprecated talloc_append_string,
 +     consistent with other deprecated functionality. Closes: #601205
 +   + Add new binary packages libpytalloc-util2 and libpytalloc-util-dev.
 +  * Bump standards version to 3.9.1 (no changes).
++  * Support nocheck in DEB_BUILD_OPTIONS rather than notest (per policy
++    4.9.1).
 +
-  -- Jelmer Vernooij <jelmer@debian.org>  Sat, 30 Oct 2010 16:04:04 +0200
++ -- Jelmer Vernooij <jelmer@debian.org>  Mon, 01 Nov 2010 19:06:20 +0100
 +
 +talloc (2.0.3~git20100517-1) experimental; urgency=low
 +
 +  * New upstream snapshot.
 +
 + -- Jelmer Vernooij <jelmer@debian.org>  Fri, 21 May 2010 00:22:17 +0200
 +
 +talloc (2.0.3~git20100506-2) experimental; urgency=low
 +
 +  * Add dependency on python for waf. Closes: #580743
 +
 + -- Jelmer Vernooij <jelmer@debian.org>  Thu, 13 May 2010 18:33:54 +0200
 +
 +talloc (2.0.3~git20100506-1) experimental; urgency=low
 +
 +  * New upstream snapshot.
 +  * Bump standards version to 3.8.4.
 +  * Update upstream location information in debian/copyright. Closes:
 +    #561529
 +  * Add missing dependencies on ${misc:Depends}.
 +
 + -- Jelmer Vernooij <jelmer@debian.org>  Thu, 06 May 2010 16:39:57 +0200
 +
 +talloc (2.0.1-1) unstable; urgency=low
 +
 +  * New upstream release
 +  * Switch to source format 3.0 (quilt)
 +  * Add myself to uploaders
 +
 + -- Christian Perrier <bubulle@debian.org>  Thu, 17 Dec 2009 22:36:31 +0100
 +
 +talloc (2.0.0-1) unstable; urgency=low
 +
 +  * New upstream release.
 +  * Bump standards version to 3.8.3.
 +
 + -- Jelmer Vernooij <jelmer@debian.org>  Fri, 11 Sep 2009 23:03:06 +0200
 +
 +talloc (1.4.0~git20090718-1) experimental; urgency=low
 +
 +  * New upstream snapshot, required for Samba 4.
 +
 + -- Jelmer Vernooij <jelmer@debian.org>  Sat, 18 Jul 2009 12:14:50 +0200
 +
 +talloc (1.3.1-2) unstable; urgency=low
 +
 +  * Bump shlibs and use symbol versioning. Closes: #536322
 +  * Bump standards version to 3.8.2.
 +
 + -- Jelmer Vernooij <jelmer@debian.org>  Sat, 18 Jul 2009 11:24:04 +0200
 +
 +talloc (1.3.1-1) unstable; urgency=low
 +
 +  * New upstream release.
 +   + Fixes build on non-Linux GNU systems. (Closes: #526069)
 +
 + -- Jelmer Vernooij <jelmer@debian.org>  Wed, 17 Jun 2009 17:07:03 +0200
 +
 +talloc (1.3.0-1) unstable; urgency=low
 +
 +  * New upstream release.
 +  * Bump standards version to 3.8.1.
 +
 + -- Jelmer Vernooij <jelmer@debian.org>  Sat, 16 May 2009 03:05:22 +0200
 +
 +talloc (1.2.1-1) unstable; urgency=low
 +
 +  [ Steve Langasek ]
 +  * Bump the shlibs in libtalloc1, since previous versions of this package
 +    have been in the wild (including in an Ubuntu release) with a smaller
 +    set of exported symbols than the current version - including talloc_pool
 +    which is used by samba.
 +
 +  [ Jelmer Vernooij ]
 +  * Add dummy watch file explaining how to obtain an upstream tarball.
 +  * New upstream release.
 +
 + -- Jelmer Vernooij <jelmer@debian.org>  Sat, 14 Mar 2009 18:48:57 +0100
 +
 +talloc (1.2.0~git20080616-1) unstable; urgency=low
 +
 +  * New upstream snapshot.
 +  * Fix symlink to library in package.
 +  * Update license (now LGPLv3) in copyright file.
 +  * Bump standards version to 3.8.0.
 +
 + -- Jelmer Vernooij <jelmer@samba.org>  Tue, 17 Jun 2008 03:02:55 +0200
 +
 +talloc (1.2.0~git20080520-1) unstable; urgency=low
 +
 +  * New upstream snapshot.
 +
 + -- Jelmer Vernooij <jelmer@samba.org>  Tue, 20 May 2008 01:40:13 +0200
 +
 +talloc (1.1.0~svn26291-1) unstable; urgency=low
 +
 +  * Support building twice in a row. (Closes: #442741)
 +  * Install SWIG file.
 +  * Upload to unstable.
 +
 + -- Jelmer Vernooij <jelmer@samba.org>  Fri, 30 Nov 2007 18:49:19 +0100
 +
 +talloc (1.1.0~svn26116-1) experimental; urgency=low
 +
 +  * Set homepage field.
 +  * New upstream snapshot.
 +  * Allow Debian maintainer uploads.
 +
 + -- Jelmer Vernooij <jelmer@samba.org>  Sun, 25 Nov 2007 18:02:48 +0000
 +
 +talloc (1.0.1-2) unstable; urgency=low
 +
 +  * Make libtalloc-dev depend on libtalloc1. (Closes: #426444)
 +
 + -- Jelmer Vernooij <jelmer@samba.org>  Sun, 25 Nov 2007 16:30:00 +0000
 +
 +talloc (1.0.1-1) unstable; urgency=low
 +
 +  * New upstream release.
 +
 + -- Jelmer Vernooij <jelmer@samba.org>  Sat, 26 May 2007 18:58:31 +0200
 +
 +talloc (1.0-1) unstable; urgency=low
 +
 +  * Initial release. (Closes: #356088)
 +
 + -- Jelmer Vernooij <jelmer@samba.org>  Wed, 30 Apr 2007 02:34:53 +0200
diff --cc debian/control
index ec728471b918806028e9d9efb37fc0719bfe7e0c,0000000000000000000000000000000000000000..9cbb9016f06e2e775fc3db8d4b90dd5da48a6eec
mode 100644,000000..100644
--- /dev/null
@@@ -1,49 -1,0 +1,49 @@@
- Depends: ${shlibs:Depends}, ${misc:Depends}
 +Source: talloc
 +Section: devel
 +Priority: optional
 +Maintainer: Jelmer Vernooij <jelmer@debian.org>
 +Uploaders: Christian Perrier <bubulle@debian.org>
 +Homepage: http://talloc.samba.org/
 +Build-Depends: debhelper (>= 7), docbook-xml, docbook-xsl, xsltproc, libpopt-dev, swig, python, python-dev, python-support
 +Standards-Version: 3.9.1
 +Vcs-Svn: svn://svn.debian.org/pkg-samba/branches/talloc/experimental
 +DM-Upload-Allowed: yes
 +
 +Package: libtalloc2
 +Architecture: any
 +Depends: ${shlibs:Depends}, ${misc:Depends}
 +Section: libs
 +Description: hierarchical pool based memory allocator
 + A hierarchical pool based memory allocator with destructors. It uses
 + reference counting to determine when memory should be freed.
 +
 +Package: libtalloc-dev
 +Section: libdevel
 +Depends: libtalloc2 (=${binary:Version}), ${misc:Depends}
 +Architecture: any
 +Description: hierarchical pool based memory allocator - development files
 + A hierarchical pool based memory allocator with destructors. It uses
 + reference counting to determine when memory should be freed.
 + .
 + This package contains the development files.
 +
 +Package: libpytalloc-util2
 +Section: libdevel
 +Depends: ${shlibs:Depends}, ${misc:Depends}
 +Architecture: any
 +Description: hierarchical pool based memor allocator - python helper library
 + A hierarchical pool based memory allocator with destructors. It uses
 + reference counting to determine when memory should be freed.
 + .
 + This package contains a library with convenience functions for use with Python
 + objects.
 +
 +Package: libpytalloc-util-dev
 +Section: libdevel
++Depends: libtalloc-dev (= ${binary:Version}), ${misc:Depends}
 +Architecture: any
 +Description: hierarchical pool based memor allocator - python helper development files
 + A hierarchical pool based memory allocator with destructors. It uses
 + reference counting to determine when memory should be freed.
 + .
 + This package contains the development files for the Python convenience library.
index 23d0e145e42b077e17c8a028e78f6f47a03c2e14,0000000000000000000000000000000000000000..8d1c7cbdc003f68bff4725679358068fa97d5f42
mode 100644,000000..100644
--- /dev/null
@@@ -1,2 -1,0 +1,3 @@@
 +usr/lib/pkgconfig/pytalloc-util.pc
++usr/include/pytalloc.h
 +usr/lib/libpytalloc-util.so
diff --cc debian/rules
index 01e28b52a0751aabc50feafb2baabc8db9fbe874,0000000000000000000000000000000000000000..73a741479607d6b728ab70da42e8215b42c19221
mode 100755,000000..100755
--- /dev/null
@@@ -1,76 -1,0 +1,78 @@@
- ifeq (,$(findstring notest,$(DEB_BUILD_OPTIONS)))
-       LD_LIBRARY_PATH=`pwd`/bin/shared ./bin/talloc_testsuite
 +#!/usr/bin/make -f
 +
 +CFLAGS = -g -Wall
 +
 +ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
 +CFLAGS += -O0
 +else
 +CFLAGS += -O2
 +endif
 +
 +DESTDIR=$(CURDIR)/debian/tmp
 +
 +conf_args = --prefix=/usr --disable-rpath-install --disable-rpath --bundled-libraries=NONE 
 +conf_args += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
 +
 +configure: configure-stamp
 +configure-stamp:
 +      dh_testdir
 +      ./autogen-waf.sh
 +      CFLAGS="$(CFLAGS)" ./configure $(conf_args)
 +      touch configure-stamp
 +
 +build: configure build-stamp
 +build-stamp:
 +      dh_testdir
 +      $(MAKE) all
++ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
++      ./bin/talloc_testsuite
 +endif
 +      touch build-stamp
 +
 +get-orig-source:
 +      ./debian/build-orig.sh
 +
 +clean: 
 +      dh_testdir
 +      dh_testroot
 +      rm -f build-stamp configure-stamp
 +      [ ! -f Makefile ] || $(MAKE) distclean
++      rm -f buildtools/wafsamba/*.pyc
++      rm -rf buildtools/bin/.waf*
 +      dh_clean
 +
 +install: build
 +      dh_testdir
 +      dh_testroot
 +      dh_prep
 +      dh_installdirs
 +      mkdir -p $(DESTDIR)`swig -swiglib`
 +      $(MAKE) install DESTDIR=$(DESTDIR)
 +      # Waf really should be doing this:
 +      ar -rc libtalloc.a bin/default/talloc_*.o
 +      cp libtalloc.a $(DESTDIR)/usr/lib
 +      dh_install --list-missing --fail-missing --sourcedir=$(DESTDIR)
 +
 +# Build architecture-dependent files here.
 +# Pass -a to all debhelper commands in this target to reduce clutter.
 +binary-arch: DH_OPTIONS=-a
 +binary-arch: build install
 +      dh_testdir
 +      dh_testroot
 +      dh_installdocs
 +      dh_installchangelogs 
 +      dh_strip
 +      dh_link
 +      dh_compress
 +      dh_fixperms
 +      dh_makeshlibs -- -c4
 +      dh_installdeb
 +      dh_shlibdeps
 +      dh_gencontrol
 +      dh_md5sums
 +      dh_builddeb
 +
 +binary-indep:
 +
 +binary: binary-arch binary-indep
 +.PHONY: build clean binary-arch binary install configure