new version 1.0.58
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0
8 Release: 58
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 CC="gcc"
38
39 ## always run autogen.sh
40 ./autogen.sh
41
42 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
43         --prefix=%{_prefix} \
44         --sysconfdir=%{_sysconfdir} \
45         --mandir=%{_mandir} \
46         --localstatedir="/var"
47
48 make showflags
49 make   
50
51 %install
52 # Clean up in case there is trash left from a previous build
53 rm -rf $RPM_BUILD_ROOT
54
55 # Create the target build directory hierarchy
56 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
57 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
58
59 make DESTDIR=$RPM_BUILD_ROOT install
60
61 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
62 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
63
64 # Remove "*.old" files
65 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
72
73 %preun
74 if [ $1 = 0 ] ; then
75     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
76 fi
77 exit 0
78
79 %postun
80 if [ "$1" -ge "1" ]; then
81         %{initdir}/ctdb restart >/dev/null 2>&1 || true
82 fi      
83
84
85 #######################################################################
86 ## Files section                                                     ##
87 #######################################################################
88
89 %files
90 %defattr(-,root,root)
91
92 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
93 %config(noreplace) %{_sysconfdir}/ctdb/functions
94 %attr(755,root,root) %{initdir}/ctdb
95
96 %{_docdir}/ctdb/README.eventscripts
97 %{_sysconfdir}/ctdb/events.d/00.ctdb
98 %{_sysconfdir}/ctdb/events.d/10.interface
99 %{_sysconfdir}/ctdb/events.d/40.vsftpd
100 %{_sysconfdir}/ctdb/events.d/41.httpd
101 %{_sysconfdir}/ctdb/events.d/50.samba
102 %{_sysconfdir}/ctdb/events.d/60.nfs
103 %{_sysconfdir}/ctdb/events.d/61.nfstickle
104 %{_sysconfdir}/ctdb/events.d/70.iscsi
105 %{_sysconfdir}/ctdb/events.d/90.ipmux
106 %{_sysconfdir}/ctdb/events.d/91.lvs
107 %{_sysconfdir}/ctdb/statd-callout
108 %{_sbindir}/ctdbd
109 %{_bindir}/ctdb
110 %{_bindir}/smnotify
111 %{_bindir}/ctdb_ipmux
112 %{_bindir}/ctdb_diagnostics
113 %{_bindir}/onnode
114 %{_mandir}/man1/ctdb.1.gz
115 %{_mandir}/man1/ctdbd.1.gz
116 %{_mandir}/man1/onnode.1.gz
117 %{_includedir}/ctdb.h
118 %{_includedir}/ctdb_private.h
119
120 %changelog
121 * Wed Aug 27 2008 : Version 1.0.58
122  - revert the name change tcp_tcp_client back to tcp_control_tcp so
123    samba can build.
124  - Updates to the init script from Abhijith Das <adas@redhat.com>
125 * Mon Aug 25 2008 : Version 1.0.57
126  - initial support for IPv6
127 * Mon Aug 11 2008 : Version 1.0.56
128  - fix a memory leak in the recovery daemon.
129 * Mon Aug 11 2008 : Version 1.0.55
130  - Fix the releaseip message we seond to samba.
131 * Fri Aug 8 2008 : Version 1.0.54
132  - fix a looping error in the transaction code
133  - provide a more detailed error code for persistent store errors
134    so clients can make more intelligent choices on how to try to recover
135 * Thu Aug 7 2008 : Version 1.0.53
136  - Remove the reclock.pnn file   it can cause gpfs to fail to umount
137  - New transaction code
138 * Mon Aug 4 2008 : Version 1.0.52
139  - Send an explicit gratious arp when starting sending the tcp tickles.
140  - When doing failover, issue a killtcp to non-NFS/non-CIFS clients
141    so that they fail quickly. NFS and CIFS already fail and recover 
142    quickly.
143  - Update the test scripts to handle CTRL-C to kill off the test.
144 * Mon Jul 28 2008 : Version 1.0.51
145  - Strip off the vlan tag from bond devices before we check in /proc
146    if the interface is up or not.
147  - Use testparm in the background in the scripts to allow probing
148    that the shares do exist.
149  - Fix a bug in the logging code to handle multiline entries better
150  - Rename private elements from private to private_data
151 * Fri Jul 18 2008 : Version 1.0.50
152  - Dont assume that just because we can establish a TCP connection
153    that we are actually talking to a functioning ctdb daemon.
154    So dont mark the node as CONNECTED just because the tcp handshake
155    was successful.
156  - Dont try to set the recmaster to ourself during elections for those
157    cases we know this will fail. To remove some annoying benign but scary
158    looking entries from the log.
159  - Bugfix for eventsystem for signal handling that could cause a node to
160    hang.
161 * Thu Jul 17 2008 : Version 1.0.49
162  - Update the safe persistent update fix to work with unpatched samba
163    servers.
164 * Thu Jul 17 2008 : Version 1.0.48
165  - Update the spec file.
166  - Do not start new user-triggered eventscripts if we are already
167    inside recovery mode.
168  - Add two new controls to start/cancel a persistent update.
169    A client such as samba can use these to tell ctdbd that it will soon
170    be writing directly to the persistent database tdb file. So if
171    samba is -9ed before it has eitehr done the persistent_store or
172    canceled the operation, ctdb knows that the persistent databases
173    'may' be out of sync and therefore a full blown recovery is called for.
174  - Add two new options :
175    CTDB_SAMBA_SKIP_CONF_CHECK and CTDB_SAMBA_CHECK_PORTS that can be used
176    to override what checks to do when monitoring samba health.
177    We can no longer use the smbstatus, net or testparm commands to check
178    if samba or its config is healthy since these commands may block
179    indefinitely and thus can not be used in scripts.
180 * Fri Jul 11 2008 : Version 1.0.47
181  - Fix a double free bug where if a user striggered (ctdb eventscript)
182    hung and while the timeout handler was being processed a new user
183    triggered eventscript was started we would free state twice.
184  - Rewrite of onnode and associated documentation.
185 * Thu Jul 10 2008 : Version 1.0.46
186  - Document both the LVS:cingle-ip-address and the REMOTE-NODE:wan-accelerator
187    capabilities.
188  - Add commands "ctdb pnn", "ctdb lvs", "ctdb lvsmaster".
189  - LVS improvements. LVS is the single-ip-address mode for a ctdb cluster.
190  - Fixes to supress rpmlint warnings
191  - AXI compile fixes.
192  - Change \s to [[:space:]] in some scripts. Not all RHEL5 packages come
193    with a egrep that handles \s   even same version but different arch.
194  - Revert the change to NFS restart. CTDB should NOT attempt to restart
195    failed services.
196  - Rewrite of the waitpid() patch to use the eventsystem for handling
197    signals.
198 * Tue Jul 8 2008 : Version 1.0.45
199  - Try to restart the nfs service if it has failed to respond 3 times in a row.
200  - waitpid() can block if the child does not respond promptly to SIGTERM.
201    ignore all SIGCHILD signals by setting SIGCHLD to SIG_DEF.
202    get rid of all calls to waitpid().
203  - make handling of eventscripts hanging more liberal.
204    only consider the script to have failed and making the node unhealthy
205    IF the eventscript terminated wiht an error
206    OR the eventscript hung 5 or more times in a row
207 * Mon Jul 7 2008 : Version 1.0.44
208  - Add a CTDB_VALGRIND option to /etc/sysconfig/ctdb to make it start
209    ctdb under valgrind. Logs go to /var/log/ctdb_valgrind.PID
210  - Add a hack to show the control opcode that caused uninitialized data
211    in the valgrind output by encoding the opcode as the line number.
212  - Initialize structures and allocated memory in various places in
213    ctdb to make it valgrind-clean and remove all valgrind errors/warnings.
214  - If/when we destroy a lockwait child, also make sure we cancel any pending transactions
215  - If a transaction_commit fails, delete/cancel any pending transactions and
216    return an error instead of calling ctdb_fatal()
217  - When running ctdb under valgrind, make sure we run it with --nosetsched and also
218    ensure that we do not use mem-mapped i/o when accessing the tdb's.
219  - zero out ctdb->freeze_handle when we free/destroy a freeze-child.
220    This prevent a heap corruption/ctdb crash bug that could trigger
221    if the freeze child times out.
222  - we dont need to explicitely thaw the databases from the recovery daemon
223    since this is done implicitely when we restore the recovery mode back to normal.
224  - track when we start and stop a recovery. Add the 'time it took to complete the
225    recovery' to the 'ctdb uptime' output.
226    Ensure by tracking the start/stop recovery timestamps that we do not
227    check that the ip allocation is consistend from inside the recovery daemon
228    while a different node (recovery master) is performing a recovery.
229    This prevent a race that could cause a full recovery to trigger if the
230    'ctdb disable/enable' commands took very long.
231  - The freeze child indicates to the master daemon that all databases are locked
232    by writing data to the pipe shared with the master daemon.
233    This write sometimes fail and thus the master daemon never notices that the databases
234    are locked cvausing long timeouts and extra recoveries.
235    Check that the write is successful and try the write again if it failed.
236  - In each node, verify that the recmaster have the right node flags for us
237    and force a push of our flags to the recmaster if wrong.
238 * Tue Jul 1 2008 : Version 1.0.43
239  - Updates and bugfixes to the specfile to keep rpmlint happy
240  - Force a global flags update after each recovery event.
241  - Verify that the recmaster agrees with our node flags and update the
242    recmaster othervise.
243  - When writing back to the parent from a freeze-child across the pipe,
244    loop over the write in case the write failed with an error  othervise
245    the parent will never be notified tha the child has completed the operation.
246  - Automatically thaw all databases when recmaster marks us as being in normal
247    mode instead of recovery mode.
248 * Fri Jun 13 2008 : Version 1.0.42
249  - When event scripts have hung/timedout more than EventScriptBanCount times
250    in a row the node will ban itself.
251  - Many updates to persistent write tests and the test scripts.
252 * Wed May 28 2008 : Version 1.0.41
253  - Reactivate the safe writes to persistent databases and solve the
254    locking issues. Locking issues are solved the only possible way,
255    by using a child process to do the writes.  Expensive and slow but... . 
256 * Tue May 27 2008 : Version 1.0.40
257  - Read the samba sysconfig file from the 50.samba eventscript
258  - Fix some emmory hierarchical bugs in the persistent write handling
259 * Thu May 22 2008 : Version 1.0.39
260  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
261    into /etc/sysconfig/ctdb
262  - Lowered some debug messages to not fill the logfile with entries
263    that normally occur in the default configuration.
264 * Fri May 16 2008 : Version 1.0.38
265  - Add machine readable output support to "ctdb getmonmode"
266  - Lots of tweaks and enhancements if the event scripts are "slow"
267  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
268    net conf introduces if used from an eventscript.
269  - Enhance tickles so we can tickle an ipv6 connection.
270  - Start adding ipv6 support : create a new container to replace sockaddr_in.
271  - Add a checksum routine for ipv6/tcp
272  - When starting up ctdb, let the init script do a tdbdump on all
273    persistent databases and verify that they are good (i.e. not corrupted).
274  - Try to use "safe transactions" when writing to a persistent database
275    that was opened with the TDB_NOSYNC flag. If we can get the transaction
276    thats great, if we cant  we have to write anyway since we cant block here.
277 * Mon May 12 2008 : Version 1.0.37
278  - When we shutdown ctdb we close the transport down before we run the 
279    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
280    after we have shutdown the transport but before we have shutdown ctdbd
281    itself this could lead to a SEGV instead of a clean shutdown. Fix.
282  - When using the "exportfs" command to extract which NFS export directories
283    to monitor,  exportfs violates the "principle of least surprise" and
284    sometimes report a single export line as two lines of text output
285    causing the monitoring to fail.
286 * Fri May 9 2008 : Version 1.0.36
287  - fix a memory corruption bug that could cause the recovery daemon to crash.
288  - fix a bug with distributing public ip addresses during recovery.
289    If the node that is the recovery master did NOT use public addresses,
290    then it assumed that no other node in the cluster used them either and
291    thus skipped the entire step of reallocating public addresses.
292 * Wed May 7 2008 : Version 1.0.35
293  - During recovery, when we define the new set of lmasters (vnnmap)
294    only consider those nodes that have the can-be-lmaster capability
295    when we create the vnnmap. unless there are no nodes available which
296    supports this capability in which case we allow the recmaster to
297    become lmaster capable (temporarily).
298  - Extend the async framework so that we can use paralell async calls
299    to controls that return data.
300  - If we do not have the "can be recmaster" capability, make sure we will
301    lose any recmaster elections, unless there are no nodes available that
302    have the capability, in which case we "take/win" the election anyway.
303  - Close and reopen the reclock pnn file at regular intervals.
304    Make it a non-fatal event if we occasionally fail to open/read/write
305    to this file.
306  - Monitor that the recovery daemon is still running from the main ctdb
307    daemon and shutdown the main daemon when recovery daemon has terminated.
308  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
309  - Define two new capabilities : can be recmaster and can be lmaster
310    and default both capabilities to YES.
311  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
312 * Thu Apr 24 2008 : Version 1.0.34
313  - When deleting a public ip from a node, try to migrate the ip to a different
314    node first.
315  - Change catdb to produce output similar to tdbdump
316  - When adding a new public ip address, if this ip does not exist yet in
317    the cluster, then grab the ip on the local node and activate it.
318  - When a node disagrees with the recmaster on WHO is the recmaster, then
319    mark that node as a recovery culprit so it will eventually become
320    banned.
321  - Make ctdb eventscript support the -n all argument.
322 * Thu Apr 10 2008 : Version 1.0.33
323  - Add facilities to include site local adaptations to the eventscript
324    by /etc/ctdb/rc.local which will be read by all eventscripts.
325  - Add a "ctdb version" command.
326  - Secure the domain socket with proper permissions from Chris Cowan
327  - Bugfixes for AIX from Chris Cowan
328 * Wed Apr 02 2008 : Version 1.0.32
329  - Add a control to have a node execute the eventscripts with arbitrary
330    command line arguments.
331  - Add a control "rddumpmemory" that will dump the talloc memory allocations
332    for the recovery daemon.
333  - Decorate the talloc memdump to produce better and easier memory leak
334    tracking. 
335  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
336    public address.
337  - Add two new controls "addip/delip" that can be used to add/remove public
338    addresses to a node at runtime. After using these controls a "ctdb recover"
339    ir required to make the changes take.
340  - Fix a couple of slow memory leaks.
341 * Tue Mar 25 2008 : Version 1.0.31
342  - Add back controls to disable/enable monitoring on a node.
343  - Fix a memory leak where we used to attach CALL data to the ctdb structure
344    when performing a local call. Memory which would be lost if the call was
345    aborted.
346  - Reduce the loglevel for the log output when someone connects to a non
347    public ip address for samba.
348  - Redo and optimize the vacuuming process to send only one control to each
349    other node containing all records to be vacuumed instead of one
350    control per node per record.
351 * Tue Mar 04 2008 : Version 1.0.30
352  - Update documentation cor new commands and tuneables
353  - Add machinereadable output to the ip,uptime and getdebug commands
354  - Add a moveip command to manually failover/failback public ips
355  - Add NoIPFallback tuneable that prevents ip address failback
356  - Use file locking inside the CFS as alternative to verify when other nodes
357    Are connected/disconnected to be able to recover from split network
358  - Add DisableWhenUnhealthy tunable
359  - Add CTDB_START_AS_DISABLED sysconfig param
360  - Add --start-as-disabled flag to ctdb
361  - Add ability to monitor for OOM condition
362 * Thu Feb 21 2008 : Version 1.0.29
363  - Add a new command to make expansion of an existing cluster easier
364  - Fix bug with references to freed objects in the ctdb structure
365  - Propagate debuglevel changes to the recovery daemon
366  - Merge patches to event scripts from Mathieu Parent :
367  - MP: Simulate "service" on systems which do not provide this tool
368  - MP: Set correct permissions for events.d/README
369  - Add nice helper functions to start/stop nfs from the event scripts
370 * Fri Feb 08 2008 : Version 1.0.28
371  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
372  - Warn if the ipvsadm packege is missing when LVS is used
373  - Dont use absolute pathnames in some of the event scripts
374  - Fix for persistent tdbs growing inifinitely.
375 * Wed Feb 06 2008 : Version 1.0.27
376  - Add eventscript for iscsi
377 * Thu Jan 31 2008 : Version 1.0.26
378  - Fix crashbug in tdb transaction code
379 * Tue Jan 29 2008 : Version 1.0.25
380  - added async recovery code
381  - make event scripts more portable
382  - fixed ctdb dumpmemory
383  - more efficient tdb allocation code
384  - improved machine readable ctdb status output
385  - added ctdb uptime
386 * Wed Jan 16 2008 : Version 1.0.24
387  - added syslog support
388  - documentation updates
389 * Wed Jan 16 2008 : Version 1.0.23
390  - fixed a memory leak in the recoveryd
391  - fixed a corruption bug in the new transaction code
392  - fixed a case where an packet for a disconnected client could be processed
393  - added http event script
394  - updated documentation
395 * Thu Jan 10 2008 : Version 1.0.22
396  - auto-run vacuum and repack ops
397 * Wed Jan 09 2008 : Version 1.0.21
398  - added ctdb vacuum and ctdb repack code
399 * Sun Jan 06 2008 : Version 1.0.20
400  - new transaction based recovery code
401 * Sat Jan 05 2008 : Version 1.0.19
402  - fixed non-master bug
403  - big speedup in recovery for large databases
404  - lots of changes to improve tdb and ctdb for high churn databases
405 * Thu Dec 27 2007 : Version 1.0.18
406  - fixed crash bug in monitor_handler
407 * Tue Dec 04 2007 : Version 1.0.17
408  - fixed bugs related to ban/unban of nodes
409  - fixed a race condition that could lead to monitoring being permanently disabled,
410    which would lead to long recovery times
411  - make deterministic IPs the default
412  - fixed a bug related to continuous recovery 
413  - added a debugging option --node-ip