Preparing for release of 3.2.5pre2
[rsync.git] / packaging / lsb / rsync.spec
1 Summary: A fast, versatile, remote (and local) file-copying tool
2 Name: rsync
3 Version: 3.2.5
4 %define fullversion %{version}pre2
5 Release: 0.1.pre2
6 %define srcdir src-previews
7 Group: Applications/Internet
8 License: GPL
9 Source0: https://rsync.samba.org/ftp/rsync/%{srcdir}/rsync-%{fullversion}.tar.gz
10 #Source1: https://rsync.samba.org/ftp/rsync/%{srcdir}/rsync-patches-%{fullversion}.tar.gz
11 URL: https://rsync.samba.org/
12
13 Prefix: %{_prefix}
14 BuildRoot: /var/tmp/%{name}-root
15
16 %package ssl-daemon
17 Summary: An stunnel config file to support ssl rsync daemon connections.
18 Group: Applications/Internet
19 Requires: rsync, stunnel >= 4
20
21 %description
22 Rsync is a fast and extraordinarily versatile file copying tool.  It can
23 copy locally, to/from another host over any remote shell, or to/from a
24 remote rsync daemon.  It offers a large number of options that control
25 every aspect of its behavior and permit very flexible specification of the
26 set of files to be copied.  It is famous for its delta-transfer algorithm,
27 which reduces the amount of data sent over the network by sending only the
28 differences between the source files and the existing files in the
29 destination.  Rsync is widely used for backups and mirroring and as an
30 improved copy command for everyday use.
31
32 %description ssl-daemon
33 Provides a config file for stunnel that will (if you start your stunnel
34 service) cause stunnel to listen for ssl rsync-daemon connections and run
35 "rsync --daemon" to handle them.
36
37 %prep
38 # Choose one -- setup source only, or setup source + rsync-patches:
39 %setup -q -n rsync-%{fullversion}
40 #%setup -q -b1 -n rsync-%{fullversion}
41
42 # If you you used "%setup -q -b1 ...", choose the patches you wish to apply:
43 #patch -p1 <patches/acls.diff
44 #patch -p1 <patches/xattrs.diff
45 #patch -p1 <patches/remote-option.diff
46 #patch -p1 <patches/db.diff
47
48 # Avoid extra perl dependencies for scripts going into doc dir.
49 chmod -x support/*
50
51 %build
52 #./prepare-source
53 %configure
54
55 make
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 make install install-ssl-daemon DESTDIR=$RPM_BUILD_ROOT
60
61 mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d $RPM_BUILD_ROOT/etc/rsync-ssl/certs
62 install -m 644 packaging/lsb/rsync.xinetd $RPM_BUILD_ROOT/etc/xinetd.d/rsync
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(-,root,root)
69 %doc COPYING NEWS.md README.md support/ tech_report.tex
70 %config(noreplace) /etc/xinetd.d/rsync
71 %{_prefix}/bin/rsync
72 %{_prefix}/bin/rsync-ssl
73 %{_mandir}/man1/rsync.1*
74 %{_mandir}/man1/rsync-ssl.1*
75 %{_mandir}/man5/rsyncd.conf.5*
76
77 %files ssl-daemon
78 %config(noreplace) /etc/stunnel/rsyncd.conf
79 %dir /etc/rsync-ssl/certs
80
81 %changelog
82 * Mon Aug 08 2022 Wayne Davison <wayne@opencoder.net>
83 Released 3.2.5pre2.
84
85 * Fri Mar 21 2008 Wayne Davison <wayne@opencoder.net>
86 Added installation of /etc/xinetd.d/rsync file and some commented-out
87 lines that demonstrate how to use the rsync-patches tar file.